arXiv:2305.16842 1

Accounting statement analysis at industry level.
A gentle introduction to the compositional approach

Germa Coenders' Nuria Arimany Serrat
University of Girona ~ University of Vic — Central University of Catalonia

Working paper. June 2023

Abstract

Compositional data are contemporarily defined as positive vectors, the ratios among
whose elements are of interest to the researcher. Financial statement analysis by means
of accounting ratios fulfils this definition to the letter. Compositional data analysis solves
the major problems in statistical analysis of standard financial ratios at industry level,
such as skewness, non-normality, non-linearity and dependence of the results on the
choice of which accounting figure goes to the numerator and to the denominator of the
ratio. In spite of this, compositional applications to financial statement analysis are still
rare. In this article, we present some transformations within compositional data analysis
that are particularly useful for financial statement analysis. We show how to compute
industry or sub-industry means of standard financial ratios from a compositional
perspective. We show how to visualise firms in an industry with a compositional biplot,
to classify them with compositional cluster analysis and to relate financial and non-
financial indicators with compositional regression models. We show an application to the
accounting statements of Spanish wineries using DuPont analysis, and a step-by-step
tutorial to the compositional freeware CoDaPack.
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1. Financial ratios as carriers of relative information

The relative nature of financial ratios, also called accounting ratios (i.e., ratios comparing
selected magnitudes in financial statements), enables them to evaluate the firm’s position
compared to its counterparts in the industry or to itself along time, taking into account
differences or evolution in firm size (Ross et al., 2003). Financial ratios have been used
in practical management performance and strategic assessment, in credit scoring, and in
research relating them to other financial or non-financial variables (Altman, 1968; Amat
Salas, 2020; Barnes, 1987; Faello, 2015; Horrigan, 1968; Qin et al., 2022; Tascén et al.,
2018; Willer do Prado et al., 2016) including for instance stock market returns or firm
survival. A typical example is the ratio of assets over equity. This ratio tells how indebted
a firm is, since assets can be decomposed into equity and liabilities, i.e., debt. It is also
referred to as leverage ratio.

While the use of standard financial ratios in diagnostics of the financial health of single
firms (or comparing e.g. two firms) is straightforward, analysing a sample of firms from
an industry requires statistical methods. Using standard financial ratios as variables in
statistical analyses within an industry has been related to a number of serious statistical
and practical problems, such as asymmetry, non-linearity, outliers, severe non-normality,
and even dependence of the results on the arbitrary decision regarding which accounting
figure appears in the numerator and which in the denominator (Arimany-Serrat et al.,
2022; Balcaen and Ooghe, 2006; Buijink and Jegers, 1986; Carreras-Sim¢é and Coenders,
2020; 2021; Cowen and Hoffer, 1982; Creixans-Tenas et al., 2019; Deakin, 1976;
Ezzamel and Mar-Molinero, 1990; Faello, 2015; Frecka and Hopwood, 1983; Lev and
Sunder, 1979; Linares-Mustaros, et al., 2018; 2022; Martikainen et al., 1995; Mcleay and
Omar, 2000; So, 1987; Watson, 1990). These serious problems have also been reported
in other scientific fields using ratios (Isles, 2020). It must be noted that when financial
ratios were first developed in the late 19th century (Horrigan, 1968), statistical analysis
methods were in their infancy, which speaks by itself for the fact that financial ratios were
not conceived with a statistical usage in mind.

Financial ratios constitute a genuine case of researchers’ and professionals’ interest in
relative rather than absolute accounting figures and thus a natural field of application of
Compositional Data (CoDa) analysis, which has the same objective. Essentially, CoDa
are arrays of strictly positive numbers for which ratios between them are considered to be
relevant (Egozcue and Pawlowsky-Glahn, 2019) which perfectly fits the notion of
financial statement analysis. The CoDa methodology offers a number of advantages in
statistical analysis of financial statements, as compared to standard financial ratios.
Among other features, CoDa treat accounting figures in a symmetric fashion in such a
way that results do not depend on numerator and denominator permutation. CoDa also
tend to reduce outliers and non-normality. Far from being a statistical refinement, the
CoDa methodology leads to very substantial differences in the analysis results whenever
they have been compared with standard financial ratios (Arimany-Serrat et al., 2022;
Carreras-Sim6 and Coenders, 2021; Jofre-Campuzano and Coenders, 2022; Linares-
Mustaros et al., 2018; 2022).

Since the seminal works by Aitchison (1982, 1986), CoDa analysis has become a well-
established methodology, notably present in accessible textbooks (van den Boogaart and
Tolosana-Delgado, 2013; Filzmoser et al., 2018; Greenacre, 2018; Pawlowsky-Glahn et
al., 2015) and software (van den Boogaart and Tolosana-Delgado, 2013; Filzmoser et al.,
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2018; Greenacre, 2018; Palarea-Albaladejo and Martin-Fernandez, 2015; Thio-
Henestrosa and Martin-Fernandez, 2005) and continues to be further developed well after
forty years (Coenders et al., 2023; Greenacre et al., 2023). The study of the relative
importance of chemical elements in geological analysis spurred most of the early interest
in CoDa (Aitchison, 1986; Buccianti et al., 2006). Nowadays, CoDa are being used in the
social sciences in general (Coenders and Ferrer-Rosell, 2020) and in finance in particular,
to answer research questions concerning the relative importance of magnitudes. Financial
examples include crowdfunding (Davis et al., 2017), bond ratings (Tallapally, 2009),
financial markets (Kokoszka et al., 2019; Ortells et al., 2016; Vega-Baquero and
Santolino, 2022a; Wang et al., 2019), municipal budgeting (Voltes-Dorta et al., 2014),
insurance (Belles-Sampera et al., 2016; Boonen et al., 2019; Gan and Valdez, 2021;
Verbelen et al., 2018), exchange rates (Gémez-Veldzquez and Coenders, 2020;
Maldonado et al., 2021a; 2021b), banking (Vega-Baquero and Santolino, 2022b),
portfolios (Glassman and Riddick, 1996; Joueid and Coenders, 2018), systemic risk (Fiori
and Porro, 2023; Porro, 2022), and equity ownership structure (Hassan et al., 2022). The
first applications in accounting and financial statement analysis are more recent
(Arimany-Serrat et al., 2022; 2023; Carreras-Sim6 and Coenders, 2020; 2021; Coenders,
2023, Creixans-Tenas et al., 2019; Jofre-Campuzano and Coenders, 2022; Linares-
Mustaros et al., 2018; 2022; Saus-Sala et al., 2021; 2023).

This article starts explaining why and how financial statements should be considered as
compositional data, including the necessary transformations. DuPont analysis, a very
simple case of financial statement analysis is used as storyline. Then, the data of an
example in the Spanish winery industry are presented. Next, four approaches to
compositional industry analysis are illustrated with the example data, including a
dedicated section is devoted to establishing relationships between financial and non-
financial indicators. The final section concludes. A software guide is included in
Appendix 2.

2. Financial statements as compositional data

A D-part composition is defined as an array of D strictly positive numbers, called parts,
the relative magnitude of which is of interest to the researcher (Aitchison, 1986):

X:(xl,xz,...,xD)withxj>O,j:1,2,...,D, (1)

Some rules have to be followed in order to introduce accounting figures in financial
statements in a D—part composition, which boil down to avoiding negative accounting
figures and their overlap (Creixans-Tenas et al., 2019):

e Even if sometimes financial ratios involve accounting figures which may be
negative, its use is advised against in the financial literature, because they can
cause a discontinuity, outliers, or even a reversal of interpretation when the
accounting figure which may be negative is in the denominator (Lev and Sunder,
1979; Linares-Mustaro6s et al., 2022). Negative accounting figures are also advised
against from the point of view of measurement theory. Computing a ratio is a
meaningful operation only for variables in a ratio scale, which need to have a
meaningful absolute zero (Stevens, 1946) and thus no negative values.

In general, accounting figures are negative because they imply some form of
subtraction of other positive accounting figures, which are the ones to be used.
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This means, for instance, that when building ratios, one should directly use
revenues and costs rather than profit or current assets and current liabilities rather
than working capital. This limitation implies no loss of information whatsoever.
For instance, a ratio conveying the same information as the standard margin ratio
(profit/revenues) can be constructed from only the non-negative magnitudes of
revenues and costs. Let x/=revenues, x:=costs, x3=x/—x>=profit. The always
positive revenues over costs ratio (xi/x2) can easily be shown to be just a
transformation of the problematic profit over revenues ratio (x3/x:):

X X, 1 1

= e @)

X, X-x, NTX X%

e It must also be taken into account that parts may not overlap. For instance, one
could not use x4: assets and xs5: non-current assets because xs is a part of x4 In
compositional data terminology, x4: assets are an amalgamation of xs: non-current
assets and xs: current assets. Using both amalgamations and their constituent parts
is extremely problematic (Pawlowsky-Glahn et al., 2015). Rather, the choice
between using only the amalgamation or only the individual parts should be made
at the problem definition stage and cannot be changed afterwards (van den
Boogaart and Tolosana-Delgado, 2013). It is not essential to use all constituent
parts, which is referred to as a subcomposition in compositional data terminology.
Accordingly, the feasible choices to handle x4 to xs are: a) to use only x4 b) to use
x5 and x¢; ¢) to use only xs; and d) to use only xs.

The ultimate choice of parts will depend on the analysis objectives or research questions.
The researchers will in principle like to select the accounting figures needed to compute
their favourite financial ratios and refine the choice by avoiding overlap and subtraction.
In this example, the parts represented by the x; variables are the following D=4 positive
and non-overlapping financial statement account categories:

* Xi:Tevenues
* Xx2:costs
* x3: liabilities
* X4 assets

These account categories are very relevant in practice because they make it possible to
compute some of the most common profitability, turnover, margin, and leverage ratios,
like those in classical DuPont analysis. DuPont analysis was developed in 1914 by
Donaldson Brown (Dale et al., 1980), and owes its name to the firm where he was working
at that time. It has continued to be in use ever since as a popular method for decomposing
the firm’s performance into a small number of financial ratios (Balezentis et al, 2019;
Chen et al., 2014; Saus-Sala et al., 2021; 2023).

According to DuPont analysis, firm profitability can be decomposed as the product of
turnover, margin and leverage, according to the following standard financial ratios, some
of which are computed from magnitudes which may be negative.
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e Turnover measures the efficiency of a firm’s use of its assets in generating sales
revenue:

Turnover=revenues/assets=x/x4. 3)
e Marginis the percentage of sales revenue that is turned into profit:
Margin=profit/revenues=(x;—x2)/x;. 4)

e Leverage measures assets generated per unit of shareholders equity. It is also a
measure of indebtedness:

Leverage=assets/equity=x4/(xs—x3). (5)
e The return on equity (ROE) is a common measure of profitability defined as:
ROE=profit/equity=(x/—x2)/(x+—x3), (6)
and can be computed as:
ROE=turnoverxmarginxleverage. (7

High margin and turnover values are always desirable. An excessive leverage can result
in an excessive indebtedness and make the firm vulnerable. In addition, leverage also
multiplies margin when margin is negative. For these reasons, leverage is a less preferred
manner of attaining high ROE figures.

DuPont analysis is chosen as storyline in this article both because of its simplicity (with
only D=4 account categories involving a handful of ratios) and its popularity. It goes
without saying that account categories could be considered in greater detail, by increasing
both the number of accounting figures D and the set of feasible financial ratios computed
from them, which would make for a more detailed financial statement analysis.

3. CoDa transformations
3.1 Pairwise log-ratios

The usual approach to statistical analysis of CoDa is to use existent standard statistical
methods on transformed data. Logarithms of ratios are the standard transformation in
CoDa (Aitchison, 1986). The simplest case of a log-ratio is that between only two
accounting figures (pairwise log-ratios, e.g., Creixans-Tenas et al., 2019; Greenacre,
2018;2019) and can also be understood as the log difference between the two magnitudes:

X

log(—lJ =log(x,)—log(x,). ®)
X

Unlike a standard ratio, which is bounded between zero and infinity, a log-ratio is

symmetric in the sense that its range is from minus infinity to plus infinity. Besides, it is

symmetric in the sense that permuting the numerator and denominator parts leads to the
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same distance from zero and affects no other property of the log-ratio than the sign
(Linares-Mustaros et al., 2022):

log[ﬁjz log(xl)—log(xz):—(log(xz)—log(xl))z—log(ﬁ} )

X, X

For instance, the correlation of an external non-financial indicator with a permuted log-
ratio equals the correlation with the original log-ratio with a reversed sign. This property
does not hold for standard financial ratios. Correlating x:/x> with a non-financial indicator
can give conflicting results with respect to correlating it with x2/x; (Linares-Mustards et
al., 2022).

Furthermore, if one of the accounting figures being compared in the ratio is close to zero,
it may lead to an outlying standard ratio when placed in the denominator and to a typical
ratio when placed in the numerator. For log-ratios placement makes no difference
(Linares-Mustaro6s et al., 2018; 2022).

Table 1 shows a toy example of seven fictional firms and two accounting figures x; and
x2. For ease of computation, we show logarithms to base 10 represented as logio(x), which
just tell how many times 10 has to be multiplied by itself in order to get the desired value.
log10(1,000,000)=6 because 10°=1,000,000. Note that, like ratios, logarithms focus on
relative differences between firms. Ratios and logarithms are thus mutually compatible.
For example, if we take firms 3,4, and 5 in the toy example in Table 1 (x2 values 100,
1,000 and 10,000), in relative terms, the difference between 1,000 and 100, which is
1,000/100=10, is the same as the relative difference between 10,000 and 1,000, which is
10,000/1,000=10. Accordingly, their log differences 3-2=1 and 4-3=1are the same.

Note that the values of x; and x> are fully symmetrical while the standard ratios x;/x> and
x2/x1 are not symmetrical at all. In the ratio x;/x2 firms 1 and 2 appear as outliers and in
the ratio x2/x; firms 6 and 7. Conversely, the logarithms of the ratios are fully symmetrical,
have no outliers, and permutation of numerator and denominator only leads to a sign
reversal.

Firm XJ X2 Xo/X1 xi/x2  logio(xs) logio(x2)  logio(x2/x;)  logio(xi/xz)
1 1,000,000 1 0.000001 1,000,000 6 0 -6 6
2 100,000 10 0.0001 10,000 5 1 -4 4
3 10,000 100 0.01 100 4 2 -2 2
4 1,000 1,000 1 1 3 3 0 0
5 100 10,000 100 0.01 2 4 2 -2
6 10 100,000 10,000 0.0001 1 5 4 -4
7 1 1,000,000 1,000,000 0.000001 0 6 6 -6

Table 1. Toy example with seven firms

Natural logarithms (to base e=2.718281828) represented as log(x) are commoner in
economics and finance, are the ones used in most compositional software and will be used
from here on, but any base could be used without affecting the properties of CoDa
analysis.
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Some log-ratios between pairs of accounting figures are especially interesting in DuPont
analysis. By definition, turnover compares revenues and assets:

» =log(ﬁj. (10)

Xy

As shown in Equation (2), comparing revenues and costs provides a notion of margin:

y2=1og[ﬁ} (11)

X,

In the same vein, comparing liabilities and assets provides a notion of leverage. Even if
it does not correspond with the standard leverage definition in Equation (5), higher
liabilities with respect to assets do imply higher leverage:

” zlog(ﬁ]. (12)

x4
ROE involves all four accounting figures and cannot be expressed as a pairwise log-ratio.

Potentially, D(D-1)/2 different pairwise log-ratios can be computed, although some of
them may fail to have any financial interpretation or theoretical interest, ratio choice
becoming a potentially problematic issue. Great care must also be made to prevent ratios
from being mutually redundant, meaning that the information of some ratios is already
contained in other (Barnes, 1987; Chen and Shimerda, 1981). For instance, in the above
example, a log-ratio computed as the ability of revenues to pay for liabilities

Y, = log(xl/x3) would be equal to y; — )5 :

Y-y, = 1og[ﬁ]-1og(ﬁJ = log(x)~log(x, )~ (log(x,) ~log(x,)) =

Xy Xy

(13)
log(x,)—log(x;) =log [%) =y,

3

Some guidelines to prevent redundancy in pairwise log-ratios are given in Greenacre
(2019) and applied in Creixans-Tenas et al. (2019) in the financial-statement context.
Greenacre (2019) recommends drawing a graph in which the accounting figures are
vertices (nodes) and the log-ratios are connections (edges). The graph must necessarily
be connected and acyclic. This means that:
e [t is possible to join any two accounting figures following the connections (i.e.,
the log-ratios).
e There may not be closed circuits, that is, when following the edges of the graph
from one accounting figure to any other, no accounting figure can be visited twice.
In other words, there is only one possible path to join any two accounting figures.

It can be proven by contradiction that such a graph has exactly D —1 edges (i.e., log-
ratios). If it has fewer edges, it cannot connect all accounting figures, and if it has more
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edges then there must be a cycle (Greenacre, 2019). D—1 pairwise log-ratios so chosen
can be proven to contain all information about the D-part compositional dataset, in other
words all information about the relative importance of the D accounting figures.

While any graph fulfilling these conditions will do the job, statistically speaking, it is
good practice to use a graph with substantive interpretation, based on expert knowledge
or in the light of the research purpose. In our DuPont analysis case we want log-ratios to
be related to the concepts of turnover, margin and leverage, namely y:, y2 and y3 , which
fortunately fulfil the conditions according to the connected acyclic graph in Fig. 1. Edges
can be drawn as arrows without affecting the graph properties, the arrows pointing at the
numerator of the log-ratio for clarification purposes only.

<

7\ V2

Vi

X4\ - X3

»
P

Figure 1. Connected acyclic graph

As an example of inappropriate log-ratio choice, when substituting y, = log(xl / x3)in

Equation (13) for y2, there would be a cycle connecting x;, x3 and x+ while x> would not
be connected.

Users must be warned that there may be more than one way to choose a sensible set of
D-1 interpretable pairwise log-ratios, and the results of some statistical analysis which
are based on distances (e.g., biplots, principal component analysis and cluster analysis as
used in Sections 6 and 7) depend on this choice (Hron et al., 2021). These statistical
methods require alternative log-ratios, as shown below.

3.2 Centred log-ratios

Pairwise log-ratios are not the only possibility in the CoDa methodology. This
methodology can completely dispense with log-ratio choice by ensuring that D so-called
centred log-ratios or clr (Aitchison, 1983) also contain all information about the relative
importance of D accounting figures. Any log-ratio the researcher might be interested in
is a function of these D centred log-ratios. Centred log-ratios compare each part, in the
numerator, with the geometric mean of all parts for each individual firm, in the
denominator. They have no accounting interpretation in themselves, but they are used as
raw data in multivariate descriptive analysis methods such as cluster analysis, principal
component analysis, and biplots, as shown in Sections 6 and 7:
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X,
clr, =log| ——~-—| with j=1,2,...,D. (14)
’ [Dw/xlxz...xD }

In our DuPont example we would have four centred log-ratios:

X
clr, =log| ———
: [14/x1x2x3x4 J

x
clr, =log| ——=—
4
XX, XX,

(15)

clr, =log

N
4
Ixx,%x,x,

clr, =log a

3 x,20,%,%,

All possible pairwise log-ratios are contained in the centred log-ratios. Note how y; can
be obtained from c/r; and clr+:

clr, —clr, =log S - —log S
1 ' XX, XX, NEIRZR
log(x,)— log(‘4/x1x2x3x4 )— (log(x4 )- log(‘4/x1x2x3x4 )) = (16)

log(x,)~log(x,)= 1og(ﬁj = .

Xy

As we will show in Sections 6 and 7, even if using centred log-ratios as raw data, the
interpretation can revert to the more easily interpretable pairwise log-ratios or even to
standard financial ratios.

4. Example data

The financial statements in this example were obtained from the SABI (Iberian Balance
sheet Analysis System, accessible at https://sabi.bvdinfo.com/) database, developed by
INFORMA D&B in collaboration with Bureau Van Dijk. Search criteria were winery
producers in Spain (NACE Rev.2 classification code 11.02 “manufacture of wine from
grape”) with available data for 2016 (n=109).

In addition to x; to x4, we consider a non-financial indicator: the qualitative variable
indicating if the firm sells at least some products using its own brand (own brand: 1=yes,
0=no). This indicator is of especial interest, since it reflects two winery business models
which have deep implications. Firms without brands tend to sell non-bottled young wines
at lower prices, while branded wines tend to be aged and expensive. Thus, firms without
brands tend to have lower margins but higher turnovers and firms with brands the opposed
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characteristics. They constitute two strategic groups pursuing high ROE values through
two different means.

Firm age in years is also included as a non-financial variable. This dataset was also used
in Linares-Mustaro6s et al. (2022) and in Coenders (2023) and is shown in Appendix 1.

All analyses were carried out with CoDaPack (Comas-Cufi and Thio-Henestrosa, 2011;
Thio-Henestrosa and Martin-Fernandez, 2005), an intuitive menu-driven freeware for
CoDa developed by the Research Group in Statistics and Compositional Data Analysis
at the University of Girona (http://ima.udg.edu/codapack/). See Ferrer-Rosell et al. (2022)
for a gentle introduction to the CoDa methodology and the CoDaPack software. A guide
to the menus used in this article is in Appendix 2.
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Figure 2. Boxplots of standard ratios in Equations (3) to (7)
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Figure 3. Boxplots of pairwise log-ratios in Equations (10) to (12)

clr.revenues clr.costs clr liabilities clr.assets

Figure 4. Boxplots of centred log-ratios in Equation (15) labelled according to the
accounting category in the numerator

The boxplot is an exploratory graphical display showing the division of values into four
equal-sized groups. Below the box there are 25 % of firms with the lowest values. The
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line dividing the box is the median. The next 25 % of cases are between the lower box
edge and the median, and the next 25 % between the median and the upper box edge.
Above the box there are 25 % of firms with the highest values. Thus, half of the firms
have values below and above the median, which represents the central firm in the sample.
Also, half of the firms have values within the box boundaries and represent the most
representative firms. The whiskers (vertical lines above and below the box) reach out to
the last non-outlying value, outliers being identified as separate points. The overall
appearance of the boxplot tells about the symmetry or lack of symmetry of the
distribution, and the extreme points tell about the presence of outliers.

As reported in the literature, pairwise and centred log-ratios (Figs. 3 and 4) tend to be
better behaved than standard ratios (Fig. 2) in terms of asymmetry and outliers. Standard
ratios are not appropriate for statistical analysis, having asymmetry, many outliers, or
both. In our example, the standard leverage ratio has especially extreme outliers and
asymmetry, followed by turnover. ROE is approximately symmetric but has also very
extreme outliers.

If centred log-ratios (Fig. 4) contain some remaining extreme outliers, the corresponding
firms can be identified and removed from the sample. This is not the case in our example
dataset.

5. Industry analysis I. Industry ratio averages

The compositional centre (Aitchison, 1997) is defined as the array of geometric means of
all firms for each individual part, normalized to unit sum for convenience (Table 2) and
is used to compute the average values for compositional data:

x1: Revenues 0.2354
x2: Costs  0.2149
x3: Liabilities 0.1590
x4: Assets  0.3907
Table 2. Compositional centre (all wineries)

This is not to be mistaken with the geometric means of all parts for each individual firm
used for computing the centred log-ratios in Equations (14) and (15).

Like ratios, geometric means focus on relative rather than absolute differences and are
mutually compatible. If we again take firms 3, 4, and 5 in the toy example in Table 1, the
geometric mean of the x2 values 100, 1,000 and 10,000 is 3/ 100x1,000x10,000 =1,000 .

This is so because, in relative terms, the difference between 1,000 and 100, which is
1,000/100=10, is the same as the relative difference between 10,000 and 1,000, which is
10,000/1,000=10. Conversely, the arithmetic mean is closer to the highest absolute values

disregarding the relative differences: (100 +1,000+10, 000) / 3=3,700.

The centre computed as a geometric mean under the CoDa approach makes it possible to
compute average standard financial ratios at industry level (Saus-Sala et al., 2021; 2023).
The geometric mean has the attractive property that the ratio of the geometric means of
two parts equals the geometric mean of their ratios. Let g(x;) be the geometric mean of



arXiv:2305.16842 13

part i over a sample of n firms:

g(xi)/g(x)=g(xi/x;). (17)

In the same toy example in Table 1, the geometric mean of the x2/x1 ratios for firms 3, 4,
and5is g (x2 /x, ) =+/0.01x1x100 =1, which is equal to the ratio of the geometric means

of x2and x1 g(x,)/g(x)=1,000/1,000=1.

Using this property, for instance, the industry average standard turnover ratio can be
computed as:

g(x1)/g(x4)=0.2354/0.3907=0.603. (18)
In the same vein, the average standard margin ratio is:
(g(x1)—g(x2))/g(x1)=(0.2354-0.2149)/0.2354=0.087, (19)
the average standard leverage ratio is:
2(x4)/(g(x4)—g(x3))=0.3907/(0.3907-0.1590)=1.686, (20)
and the average ROE is:
(g(xr)—g(x2))/(g(x4)—g(x3))=(0.2354-0.2149)/(0.3907-0.1590)=0.089. (21)

The arithmetic mean does not have this property. Computing first arithmetic means at
industry level and then standard financial ratios between those means may stand in
contradiction with the results of computing first standard ratios at firm level and then the
ratio arithmetic means (Saus-Sala et al., 2021).

In the same toy example in Table 1, the arithmetic mean of the x2/x1 ratios for firms 3, 4,
and 5 is (0.01 +1+ 100)/3 =33.67 which is not the ratio of the arithmetic means of x1 and
x2 3,700/3,700=1.

This makes it possible to present the results of compositional industry analysis in terms
of standard financial ratios, which are better understood by the accounting community
than the CoDa log-ratios. The analysis may be repeated by previously identified
subdivisions within the industry, for instance firms having or not at least one brand of
their own (Tables 3 and 4).

Group 0 (no) — n=24 Group 1 (yes) — n=85
x1: Revenues 0.2684 0.2259
x2: Costs 0.2522 0.2045
x3: Liabilities 0.1558 0.1593
x4: Assets 0.3237 0.4102

Table 3. Compositional centre of wineries with (1) and without (0) their own brand
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Turnover Margin Leverage ROE

No brand (0) 0.829 0.060 1.928 0.096
Brand (1) 0.551 0.095 1.635 0.085
Overall 0.603 0.087 1.686 0.089

Table 4. Standard ratios of wineries with (1) and without (0) their own brand computed
from the geometric means as in Equations (18) to (21)

As expected, firms with no brands have lower margin and higher turnover. For instance,
the average turnover for firms with no brands can be computed as 0.2684/0.3237=0.829
and for firms with brands as 0.2259/0.4102=0.551. Firms with no brands also have higher
leverage. All in all, the ROE is more favourable for firms with no brands, at the expense
of a higher indebtedness.

One may wonder why industry averages are not computed from log-ratios. Implicitly they
are. It can be proven that the arithmetic means computed on the centred log-ratios are
equivalent to the geometric means computed from the accounting figures that have been
presented here. The only thing which needs to be done is to exponentiate the arithmetic
clr means (Aitchison, 1997). In this article we use the geometric mean representation due
to its intuitive appeal.

6. Industry analysis II. Visualisation of individual firms with the CoDa
biplot

Like any other statistical data, compositional data require visualization tools to help
researchers interpret large data tables with many firms and parts. To this end, Aitchison
(1983) extended the well-known principal component analysis procedure to the
compositional case. This method belongs to the family of multivariate statistical analysis,
and the extension boils down to submitting the D centred log-ratios in Equation (15) to a
principal component analysis based on the covariance matrix. A compositional principal
component analysis computes a small number of uncorrelated linear combinations of the
centered log-ratios, called dimensions, which explain the highest possible portion of total
variance. In this way the original data set with potentially many variables can be
summarized with just a few dimensions which are suitable for a graphical display.

The two first dimensions are represented in the so-called covariance CoDa biplot
(Aitchison and Greenacre, 2002), which can be understood as the most accurate graphical
representation of a compositional data set in two dimensions. The goodness of fit is
indicated by the the percentage of explained variance of the centred log-ratios by the first
dimensions. The CoDa biplot for financial statement data plots each centred log-ratio
representing the accounting figure in the numerator as a ray. Individual firms appear as
points.

In our example, the percentage of explained variance by the first two dimensions is very
high at 98.99% thus arguing for an extremely good biplot accuracy. The information in
the original data can be represented in a two-dimensional biplot with very high precision.

Carreras-Sim6 and Coenders (2020) and Saus-Sala et al. (2021; 2023) highlight the most
important interpretational tool of the CoDa biplot in financial statement analysis. The
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orthogonal projection of all firms along the direction defined by the link between the
vertices of a pair of rays (referred to the accounting figures in the numerator of the centred
log-ratio) shows an approximate ordering of firms according to the pairwise log-ratio
between the corresponding two accounting figures. In this way, the CoDa biplot is also a
visual representation of any of the D(D—1)/2 possible financial ratios computed from any
two accounting figures. The used can draw as many links as he or she wishes. Since the
analysis is anyway run on centred log-ratios, redundancy is not a problem, although only
long links showing high variance pairwise log-ratios tend to lead to informative
directions. Thus, pairwise ratios should not be drawn when the links are very short, in
other words, when the vertices of the two involved centred-log-ratio rays are close
together.

In our case the three pairwise log-ratios of interest are y; (turnover), y> (margin) and y3
(leverage) and have thus been drawn above the biplot (Fig. 5). Since ROE cannot be

expressed as a pairwise ratio, it cannot be represented in the biplot.

clr.Liahilities

e
@0

clr.Costs

clr. Revenues

clr.Assets
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[ ] o1_

Figure 5. CoDa biplot with added turnover (y1) margin (y2) and leverage (y3)
directions. Firms with an own brand in black, without in gray.
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The ability to visually interpret ratios between any two magnitudes is of great interest in
financial statement analysis in general and in DuPont analysis in particular (Saus-Sala et
al., 2021; 2023). For instance, the y: line representing margin links the vertices of
revenues and costs. Firms situated at the bottom and to the left are the ones with the
highest margin (in the high-revenue side of the line) and firms situated at the top and to
the right (in the high-cost side of the line) are the ones with the lowest margin.

In more precise terms, firms are projected orthogonally (forming a 90-degree angle) on
each of the yi, y2 and ys lines. For instance, firm 16 has the highest orthogonal projection
on y2 and the lowest on ys. Thus, it is a firm with a very high margin and a very low
leverage. Firm 59 has a very low turnover and firm 52 has a very high turnover. As a
whole, firms without a brand (marked as grey) have a comparatively lower margin, higher
leverage and higher turnover than firms with a brand (marked as black). The closest firms
to the origin of coordinates, like firms 8, 17, 41, 71, 81 and 91, are also the closest to the
industry average described in Section 5.

The compositional biplot thus becomes an intuitive and useful tool for strategic analysis
(Carreras-Sim6 and Coenders, 2020) as it allows researchers to quickly identify
individual firms competing on the basis of margin, on the basis of turnover, or on the
basis of leverage.

7. Industry analysis III. Industry heterogeneity assessment with cluster
analysis

Very rarely can an industry be assumed to represent one single homogeneous financial-
statement pattern. Cluster analysis is another popular multivariate statistical method
which aims to extracting groups or clusters of individuals (i.e., firms) in such a way that
individuals of the same group are as similar (homogeneous) as possible according to the
variables of interest and individuals in the different groups are as dissimilar as possible
(Kaufman and Rousseeuw, 1990). Compositional cluster analysis boils down to
performing an otherwise standard cluster analysis on the D centred log-ratios in Equation
(15) (Martin-Fernandez et al., 1998; Ferrer-Rosell and Coenders, 2018). If centred log-
ratios are used as data, Euclidean distances become equal to the standard Aitchison’s
distances used in compositional data analysis (Aitchison, 1983; Aitchison et al., 2000),
and any standard clustering method handling Euclidean distances can be used. This
includes, among others, two popular clustering methods in financial-statement analysis
(Linares-Mustaros et al., 2018): Ward’s method and the k-means method.

In the financial-statement context, compositional cluster analysis can be used to identify
subgroups of firms with similar financial-statement structures within an industry
(Coenders, 2023, Jofre-Campuzano and Coenders, 2022; Linares-Mustaros et al., 2018;
Saus-Sala et al., 2021; 2023). This has sometimes been called “profiling financial
performance and financial distress”.

In the example we use the ~~-means method. To classify the individuals into £ clusters,
this method takes £ individuals (i.e., firms) as initial cluster centres, and each of the
remaining individuals is assigned to the cluster with the closest centre. The centres are
recomputed as the means of the individuals in each cluster, and the reassignment is
repeated. The process goes on until no individual moves cluster between one step and the
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next. Since the final result may depend on which individuals are taken as initial centres,
the process is repeated several times with different initial cluster centres randomly chosen.
CoDaPack performs such 25 repetitions. Only the solution with the highest cluster
homogeneity (lowest sum of variances within the clusters) is presented to the user.

The appropriate number of clusters is rarely known in advance. Several statistical criteria
are available to decide the best £ after doing classifications with reasonable numbers of
clusters, for instance from k=2 to &=8. In our example, a 3-cluster solution maximises
both the Average silhouette width (Kaufman and Rousseeuw, 1990) and the Calinski-
Harabasz index (Calinski and Harabasz, 1974). The number of clusters can also be chosen
according to interpretability: adding a cluster makes sense if it adds a meaningfully
different financial-statement profile, without leading to any of the existing clusters being
very small. One starts with 2 clusters and keeps on adding clusters as long as the above
statement holds. From our own experience, the ideal number of clusters is usually
between 3 and 5. In a two-cluster solution one cluster merely has opposite characteristics
from the other in all ratios, which is rather uninteresting. A solution with more than 5
clusters tends to be very hard to interpret.

From the cluster compositional centres, the standard financial ratios in Equations (3) to
(7) can be computed to represent an average firm in the cluster (Tables 5 and 6), which
makes for a simple interpretation. The biplot can also be redrawn with the cases coloured
by the cluster membership variable (Fig. 6).

Cluster 1 (23 firms) has the lowest turnover, leverage and ROE and the highest margin,
Cluster 2 (50 firms) the highest leverage, and Cluster 3 (36 firms) the highest turnover
and ROE and the lowest margin. This can be seen also from the situation in the biplot in
reference to the directions defined by the pairwise log-ratios y;, y2 and ys.

Cluster 1 —n=23 Cluster 2 — n=50 Cluster 3 — n=36
x1: Revenues 0.1923 0.1934 0.3090
x2: Costs 0.1549 0.1797 0.2979
x3: Liabilities 0.0788 0.2281 0.1324
x4: Assets 0.5739 0.3988 0.2607

Table 5. Compositional centre of wineries per cluster

Cluster Turnover Margin Leverage = ROE
1 0.335 0.194 1.159 0.076
2 0.485 0.071 2.336 0.080
3 1.185 0.036 2.032 0.087

Table 6. Standard ratios of wineries computed from the cluster geometric means as in
Equations (18) to (21)
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Figure 6. Compositional biplot with firm points coloured by cluster membership

Mosaic plots can be used to relate the cluster membership to categorical non-financial
indicators like having or not having an own brand. Fig. 7. shows clusters 1 and 2 to be
more prevalent in wineries with an own brand (1), and cluster 3 in firms without any own
brand (0). This makes theoretical sense as Cluster 3 has the highest turnover and the
lowest margin.
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Figure 7. Mosaic plot of cluster and having (1) or not (0) an own brand. Bar heights are
percentages of firms with and without brand within a cluster. Bar widths are cluster
sizes. Bar areas are firm counts within each of the cluster-brand combinations

Boxplots can be used to relate the cluster membership to numerical non-financial
variables such as firm age. Fig. 8 shows the median age to be lower for cluster 3.
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Figure 8. Boxplots of firm age in years by cluster
8. Industry analysis I'V. Relationships to non-financial indicators

Up to now we have dealt with descriptive statistical methods. This section is devoted to
statistical modelling, inference and testing. Centred log-ratios are recommended for
multivariate descriptive statistical analyses (e.g., cluster analysis, biplot, principal
component analysis as used in Sections 6 and 7) but not for certain types of statistical
models, for which alternative log-ratio transformations are preferrable. Even of more
practical importance, centred log-ratios are not directly interpretable as variables in
accounting, while in statistical models the interpretation of the included variables is a
crucial issue, which makes a set of D—1 pairwise log-ratios a preferable option. As
indicated in Section 3, in order to include the whole information in the D parts while
avoiding redundancy, log-ratios must form a connected acyclic graph.

According to the boxplots (Fig. 9), at first sight, firms with a brand have higher margin
(12) but lower turnover (y:) and lower leverage (y3) according to Equations (10) to (12).
There are far fewer outliers and far less asymmetry than in Fig. 2. According to the
scatterplots (Fig. 10), at first sight there is little or no relationship between firm age and
any of the pairwise log-ratios, and there might be an outlier in firm age, with a firm aged
over 100 years.
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Figure 9. Boxplots of pairwise log-ratios in Equations (10) to (12) for wineries with (1)
and without (0) their own brand
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Figure 10. Scatterplots of pairwise log-ratios in Equations (10) to (12) with firm age in
years

Once suitable log-ratios have been computed, a statistical model can be performed with
standard methods, starting with ordinary-least-squares linear regression in which the
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composition is made to dependent on one or more non-compositional predictors (Egozcue
et al., 2011) which may not only be numeric but also qualitative with two categories (i.e.
binary), as long as the two categories are coded as 0 and 1. This makes it possible to relate
the financial indicators contained in the financial-statement composition to non-financial
indicators.

An alternative possibility not covered here is that the composition predicts one single
dependent numeric variable (Aitchison and Bacon-Shone, 1984; Coenders and
Greenacre, 2023; Coenders and Pawlowsky-Glahn, 2020). The reader non familiar with
ordinary-least-squares linear regression and with statistical hypothesis testing is advised
to resort to any introductory statistics handbook.

In our example we use firm age in years and the non-financial indicator distinguishing
firms with a brand as predictors of the pairwise log-ratios. The qualitative variable is
appropriately coded as 0 (no brand) and 1 (at least one brand). D—1 linear regression
equations are specified as:

y=o+ Bz + Bz, g
V=0t Bz + Bz, 6, (22)

Vs =a5+ Pz + Bz, + &,

Where y; to y3 are the pairwise log-ratios in in Equations (10) to (12), z; and z> are the
predictor variables, the « parameters are the intercept terms, the  parameters are effects
of each of the z predictors on each of the pairwise log-ratios and the terms are the random
disturbances standing for the part of the pairwise log-ratios which is not explained by the
predictors.

It is not advisable to include some log-ratios at the right-hand side of the regression
equations to predict another log-ratio. This is so because ratios involving the same parts
of the composition are prone to spurious (i.e., false) correlations, a fact that was revealed
by Pearson himself as he was developing the correlational concept (Pearson, 1897).

The following six statistical hypotheses are tested corresponding to the £ parameters in
the regression equations (22):

Ho: £11=0 (firm age does not affect turnover)
Ho: £21=0 (firm age does not affect margin)
Ho: f51=0 (firm age does not affect leverage)
Ho: p12=0 (having or not a brand does not affect turnover)
Ho: 22=0 (having or not a brand does not affect margin)
Ho: f52=0 (having or not a brand does not affect leverage).

The p-value associated to each statistical test indicates the risk involved in rejecting the
hypothesis. If this is low (e.g., lower than 0.05), the hypothesis can be rejected, leading
to the conclusion that the predictor at hand does affect the involved log-ratio, in other
words that its effect is statistically significant. We can thus assess the statistical
significance of the differences between firms having or not a brand, intuitively revealed
by Table 4 and the boxplots in Fig. 9, taking firm age into account.
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According to Table 7, only turnover is significantly different depending on whether firms
have or fail to have an own brand (p-value = 0.0064). The negative sign of the coefficient
(-0.4068) indicates that firms with a brand (labelled as 1) have a lower turnover, keeping
firm age constant. A positive sign would have indicated the opposite. Firm age is not
significantly related to any of the log-ratios.

Age (z1) Brand (z2)
Bestimate  p-value  SBestimate p-value  Adjusted R?
yi1 (turnover) -0.0002 0.9538 -0.4068 0.0064 0.0565
y2 (margin) -0.0005 0.4004 0.0447 0.1762 0.0009
ys3 (leverage) -0.0019 0.5470 -0.1869 0.2660 0.0013

Table 7. Regression estimates for the pairwise log-ratios predicted by firm age and the
variable indicating wineries with a brand of their own, coded as 1

The adjusted R? indicate the percentages of variance of each pairwise log-ratio explained
by the z variable(s). In our case they are very low at 5.65 %, 0.09 % and 0.13 %, thus
showing that other non-financial indicators not considered here may have the lion’s share
in explaining the behavior of turnover, margin, and leverage in wineries.

9. Conclusions

Compositional Data (CoDa) can be used to advantage to distil the relative magnitudes of
accounting figures, which lies at the ground of researchers’ and professionals’ interests
when performing financial statement analysis. CoDa solve the main drawbacks of
standard financial ratios in statistical analysis at industry level, such as extreme skewness,
outliers and dependence of the results on the arbitrary permutation of numerator and
denominator.

These permutations are not uncommon in practice (Linares-Mustards et al., 2022). For
instance, solvency can be defined as x4/x3 and indebtedness as x3/x+. In our example,
regressing solvency thus defined on having or not a brand does not lead to significant
differences, while regressing indebtedness on having or not a brand leads to significantly
lower indebtedness in firms with a brand.

The common notion of average financial structure must be expressed as geometric means.
Geometric means have the additional attractive property in industry analysis that the mean
ratio equals the ratio between means. Once geometric means of accounting values have
been computed for the whole industry or any subdivision of it, interpretation may revert
to standard financial ratios for an ease of communication with the accounting and
management community. The relative statistical complexity of the log-ratios will thus be
hidden from the end reader.

Classical multivariate analysis tools can be used on CoDa after transforming the data by
means of centred log-ratios. In particular, the principal component analysis biplot
visualizes all firms with respect to the ratio of any pair of accounting figures, and cluster
analysis makes it possible to draw groups with similar financial statement profiles.
Clusters can be related to external variables in the usual way, for instance with simple
mosaic plots or boxplots. Cluster analysis results can also be expressed in terms of
standard financial ratios with geometric means. Submitting standard financial ratios to
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cluster analysis leads to some clusters being uninformative, small, or even made up only
with outliers (Linares-Mustards et al., 2018; Jofre-Campuzano and Coenders, 2022), In
our example, submitting the standard turnover, margin, leverage and ROE ratios to the .-
means classification led to an uninterpretable 3-cluster solution with cluster sizes 101, 7
and 1.

Statistical modelling is also possible by means of D—1 pairwise log-ratios, which can play
the role of dependent or explanatory variables in a linear regression model. Other log-
ratio transformations are also candidates for this purpose, like the so-called isometric log-
ratio coordinates (Egozcue et al., 2003; Pawlowsky-Glahn and Egozcue, 2011) used for
instance by Arimany-Serrat et al. (2022; 2023); Carreras-Sim6 and Coenders (2021);
Coenders (2023); and Linares-Mustards et al. (2018; 2022).

Any positive non-overlapping accounting figures may be used to define any set of ratios,
beyond the very simple DuPont-analysis case. For instance, current and non-current
assets could have been used instead of total assets, and current and non-current liabilities
could have been used instead of total liabilities. This would have made it possible to
define ratios of debt maturity (non-current over current liabilities), and liquidity (current
assets over current liabilities). See Arimany-Serrat et al. (2023); Carreras-Sim6 and
Coenders (2020; 2021); Coenders (2023); Creixans-Tenas et al. (2019); Jofre-Campuzano
and Coenders (2022); and Linares-Mustaros et al. (2018). It is also possible to include
non-financial figures if they result into meaningful ratios (e.g., the number of employees
appears in the average wage ratio, the sales per employee ratio, and so on). Finally,
accounting figures can be weighted in order to equalize their impact on the results, in a
similar way as standardization is used in common statistical analysis (Jofre-Campuzano
and Coenders, 2022).

A commonly mentioned limitation of CoDa is that the accounting figures of interest may
contain no zero values for log-ratios to be computed (Martin-Fernandez et al., 2011).
However, the same holds for standard financial ratio analysis: a zero accounting figure is
not relative to anything and if it is in the denominator, the standard ratio cannot even be
computed. Unlike the case in standard financial ratio analysis, CoDa include an advanced
toolbox for zero imputation prior to log-ratio computation under the most common
assumptions. This provides CoDa with a head advantage compared to standard financial
ratio analysis in the presence of zeros, with Palarea-Albaladejo and Martin-Fernandez
(2008; 2015) and Martin Fernandez et al. (2011; 2012) being key references. This makes
financial statement analysis possible even when some accounting figures of interest equal
zZero.

In the literature of compositional financial statement analysis, the most popular
imputation method by far is the log-ratio EM method (Palarea-Albaladejo and Martin-
Fernandez, 2008). This method is similar to the standard EM method for imputing missing
data, with the restriction that imputed values must be below the minimum observed value
of each part or below any other limit specified by the user.

Having said this, these zero imputation methodologies require the number of zero values
to be small, ideally below 20 % (Palarea-Albaladejo and Martin-Ferndndez, 2008). This
may impede dividing assets and liabilities into very detailed accounts, such as buildings,
trade names, inventory, accounts receivable, marketable securities, accounts payable,
short-term loans, bonds, long-term loans, capital leases, and so on, some of which are
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zero for a large portion of firms.

The cited current and past research in compositional financial statement analysis includes
a wide range of industries, like manufacture of pharmaceutical preparations and
manufacture of wearing apparel (Linares-Mustaros et al., 2018), hospitals (Creixans-
Tenas et al., 2019), grocery (Carreras-Sim6 and Coenders, 2020), retail trade (Carreras-
Sim¢ and Coenders, 2021), wineries (Arimany-Serrat et al., 2022; 2023; Coenders, 2023;
Linares-Mustar6s et al., 2022), tourism (Saus-sala et al., 2021; 2023), and sale of
automotive fuel (Jofre-Campuzano and Coenders, 2022), and has potential to expand to
any other industry. Besides the statistical methods described here, compositional financial
statement analysis has used partial-least-squares structural equation modelling (Creixans-
Tenas et al., 2019), vector autoregressive models (Carreras-Simé and Coenders, 2021),
weighted classification (Jofre-Campuzano and Coenders, 2022), and panel regression
models (Arimany-Serrat et al., 2023), and has potential to expand to any other statistical
method used in accounting and finance. Published research also includes a number of
research topics. Arimany-Serrat et al. (2022) extend the CoDa methods to the analysis of
the cash flow statement, Carreras-Sim6 and Coenders (2021) relate asset and capital
structures, Creixans-Tenas et al. (2019) study the impact of social responsibility, and
Arimany-Serrat et al. (2023) the impact of Covid-19. The method has potential for any
business research project using statistical methods and including financial-statement
information among the set of study variables.
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Appendix 1: Dataset

Firm  x; X2 X3 X4 Brand Age | Firm X1 X2 X3 X4 Brand Age
1 10386 12987 34048 41456 1 22 | 56 32692 32439 13100 19502 1 75
2 8004 8416 24104 30085 1 28 | 57 38207 38432 41987 58921 0 24
3 16692 11755 7440 101358 0 26 | 58 195083 198107 201348 365287 1 90
4 11510 10707 16828 28410 1 10 | 59 24595 15318 31384 195823 0 20
5 16742 16769 8579 22967 0 18 | 60 14124 14380 9363 9471 1 14
6 34840 32015 44345 72394 1 82 | 61 99027 76807 59139 183307 1 34
7 31070 26010 6234 35945 1 66 | 62 14321 14300 5464 20418 1 53
8 21140 17844 12138 29176 1 33 | 63 16032 15943 8013 16862 1 72
9 96411 72656 73509 324641 1 31 | 64 24123 23898 23933 26902 1 61
10 13421 11525 3694 25257 1 35 1 65 12463 12157 17251 19627 0 16
11 60202 57587 16335 71165 0 2 66 69561 54111 68227 256252 1 24
12 72582 65071 5470 83535 0 3 67 8775 8603 17703 23320 1 59
13 23261 18073 23986 56463 1 28 | 68 259734 240445 104154 286414 0 39
14 13941 13786 6892 8520 0 22 | 69 123735 122071 43130 116517 1 9
15 11837 9294 4655 25422 1 21 | 70 537137 526427 508236 748117 1 88
16 12452 9589 4957 92492 1 22 | 71 169304 157689 114442 329924 1 46
17 32956 30230 26594 66630 1 15 | 72 31456 31094 23582 35752 1 19
18 18307 13587 3928 39874 1 42 | 73 30027 31633 9857 66558 1 76
19 16856 13424 5149 55904 1 15| 74 10786 10202 7126 40587 1 13

20 25625 23361 10730 20054 1 15 | 75 38305 36653 44082 53633 1 14
21 12616 12241 2835 6537 0 13 | 76 673107 617452 594441 865845 1 45
22 16968 14287 13806 37401 1 6 77 10562 10111 5004 27996 0 5

23 18149 11913 19651 35564 1 21 | 78 43787 38357 22471 96302 1 39
24 48717 32328 26678 139254 1 20 | 79 26040 23274 10976 23926 1 40
25 24000 23379 7775 13899 1 13 | 80 57164 51805 41207 72790 1 31
26 33709 32826 15334 20037 1 19 | 81 24048 21513 15137 45304 1 51
27 38566 38720 25590 28311 0 16 | 82 26784 25520 12179 13447 0 4

28 12260 12361 52911 64438 1 23 | 83 56259 54911 37037 55362 1 26
29 13597 12508 19147 35585 1 44 | 84 16940 17179 16747 18456 0 43
30 34434 30497 58473 78393 1 13 | 85 29747 24915 42917 77024 1 1

31 40704 39748 23538 32136 0 21 | 86 14779 11694 21851 65560 1 35
32 29981 28923 11511 16614 0 15 | 87 29386 28777 33508 44656 1 37
33 21271 16977 6748 64526 1 42 | 88 268730 257330 104579 391390 1 32
34 14932 11931 13355 37558 1 20 | 89 65237 59441 68706 97750 0 33
35 24184 23942 24460 32562 1 23 | 90 11314 7430 17442 45345 1 28
36 19633 18906 29641 42961 1 30 | 91 43979 41265 30812 86256 1 14
37 11877 11765 16962 18394 0 12 | 92 14970 14174 21473 27310 1 24
38 11288 11165 4507 11172 1 75 | 93 135233 120931 48661 221337 1 43
39 19528 16678 13119 42340 1 31 | 94 11751 16125 15105 16206 1 31
40 51184 45551 20999 57881 1 31 | 95 34899 21295 13763 100585 1 21
41 10930 12668 8845 25496 1 42 | 96 21327 21394 9672 15772 1 49
42 18795 18279 17940 24707 1 63 | 97 11053 10993 5787 9792 0 37
43 10957 10920 4594 10443 1 37 | 98 11584 9981 3918 22686 1 83
44 17586 16851 19432 49583 1 33 1 99 12980 12574 13922 17771 0 57
45 44509 35925 49157 97699 1 43 | 100 16625 16603 17980 31256 0 40
46 19018 17169 32786 58143 1 86 | 101 53989 54545 61072 81757 1 44
47 24987 24663 42050 50722 1 71 | 102 62461 60327 21805 29618 0 34
48 9598 8302 5614 20458 1 27 | 103 10399 10051 11465 19488 1 10
49 28533 15219 19654 122212 1 52 | 104 32673 29301 7908 40683 1 65
50 23628 23571 9355 17945 1 6 | 105 86395 85927 45882 55318 1 18
51 16426 15889 13243 64989 1 35 1 106 11862 10339 2778 38565 1 30
52 19549 19429 5993 8697 0 26 | 107 13364 11772 15292 46389 1 25
53 56892 60958 31041 59388 1 62 | 108 30172 29610 15320 26823 1 20
54 13024 12203 5208 58275 1 41 | 109 9316 8720 16050 21057 0 20
55 11031 9801 6031 8764 1 9
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Appendix 2: Selected CoDaPack menus

Opening or importing data: The File menu handles opening and saving data files,
including importing and exporting them to a variety of formats (.xls, .xlsx, .csv, .txt, and
.RData). File names may contain only letters in the English alphabet, numbers and
underscores “ .

For instance, to import an Excel file, select the File »Import >Import XLS Data menu.
The Excel file must only contain one sheet with the variable names in the first row and
the data from the second row onwards. Data may be text or numbers, not formulas.
Variable names may contain only letters in the English alphabet, numbers and
underscores “_”, and may not include spaces. Zeros in accounting data must be entered
as such; missing values in non-accounting data as “NA”.

When importing the data, CoDaPack will assign variable types to the data. Numeric
columns appear in white and categorical columns in yellow. The user may change that
status if the variables actually contain numbers (Data >Manipulate >Categorical to
Numeric or Data >Manipulate »>Numeric to Categorical).

After importing the data it is advisable to store them in CoDaPack’s native .cdp format
(File »Save as menu).

Zero imputation: If there are zeros in the accounting data, they have to be imputed first.
The Irregular Data »Zpatterns Plot menu, computes percentages of zeros per part and
overall, after introducing the parts xs,..., x4 into the Selected Data box with the Show
Percentages option.

The Irregular Data >Set Detection Limit menu makes it possible to set the detection limit
as the minimum value of each column after introducing the parts x,..., x4 into the Selected
Data box with the Take Minimum of Each Column option.

The Irregular Data>Logratio-EM zero Replacement menu is a convenient zero
imputation method (Palarea-Albaladejo and Martin-Fernandez, 2008), after introducing
the parts xy,...,xs into the Selected Data box with the default options. 4 new variables free
of zeros are created at the end of the data file. The File >Save as menu will store the
enlarged file.

Fig. 2: To plot standard financial ratios, the best alternative is to have them first computed
with Excel, copy and paste them as data to remove the formulas within Excel, and import
them into CoDaPack. The Graphs »Boxplot menu produces the boxplots themselves after
introducing the standard ratios into the Selected Variables box, with the option Draw
mean »None.

Fig. 3: The Data>Transformations >ALR menu stores the pairwise log-ratios as
additional variables at the end of the data file, after introducing the two parts in the
Selected Data box, the numerator part first, the denominator part last, and with the Raw-
ALR option. The File »Save as menu will store the enlarged file.

For instance, when introducing x; and x4 to compute y;, CoDaPack names the transformed
variable alr.x1_x4. By double clicking on the variable name the user may edit it, taking
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into account that edited names may contain only letters in the English alphabet, numbers
and underscores “ ” without spaces. After editing each name, the return key much be
pressed.

Once transformed, pairwise log-ratios can be treated with standard statistical methods.
Thus, for the purpose of descriptive statistical analysis the menu Statistics >Classical
statistics summary has to be used instead of the menu Statistics »Compositional statistics
summary.

The Graphs >Boxplot menu produces the boxplots themselves after introducing the
pairwise log-ratios into the Selected Variables box, with the option Draw mean »>None.

Fig. 4: The Data »Transformations »CLR menu stores the centred log-ratios as additional
variables at the end of the data file, after introducing all parts xi,..., x4 into the Selected
Data box and with the Raw-CLR option. The File >Save as menu will store the enlarged
file.

CoDaPack names the transformed variables clr.x1 to clr.x4. By double clicking on the
variable names the user may edit them, taking into account that edited names may contain
only letters in the English alphabet, numbers and underscores “  without spaces. After
editing each name, the return key much be pressed.

The Graphs »Boxplot menu produces the boxplots themselves after introducing the clr
variables into the Selected Variables box, with the option Draw mean »>None.

Tables 2 and 3: The Statistics »Compositional statistics summary menu computes the
compositional centre as geometric means, after introducing the parts xs,..., x4 into the
Selected Data box with only the Center option selected.

Clusters or any other subdivision within the industry can optionally be defined by a
variable entered in the Groups box. The grouping variable must be stored as categorical
(marked as yellow in the data table), or else must be previously transformed with the
menu Data >Manipulate >Numeric to Categorical.

Figs. 5 and 6: The Graphs > CLR biplot menu depicts the covariance biplot. The menu
computes centred log-ratios internally so that the original accounting figures xi,..., x4
must be entered in the Selected data box. Points can be coloured according to a categorical
variable defining clusters or any other subdivision within the industry (Groups box). The
grouping variable must be stored as categorical (marked as yellow in the data table), or
else must be previously transformed with the menu Data >Manipulate »Numeric to
Categorical.

Once the biplot is drawn, the Data >Show observation names option can be used to
identify individual firm points by row numbers in the data file. If the user wants points to
be labelled by a variable in the data file rather than by row, he or she must first select the
Data »>Add observation names option.

CoDaPack does not draw the pairwise log-ratios ys to ys. To prepare this article they were
added afterwards with a graph editing software.
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Table 5: The Statistics »Multivariate analysis »>Cluster »k-means menu performs k-
means clustering and allows the user to select the desired Number of clusters. The menu
computes appropriate log-ratios internally so that the original xi,..., x4 accounting figures
must be entered in the Select composition box. A new categorical variable named Group
containing cluster membership is stored at the end of the data file. The File >Save as
menu will store the enlarged file.

An alternative possibility is to let the procedure decide the optimal number of clusters
between 2 and a maximum number of clusters decided by the user (Find optimal number
between 2 and...). Optimality may be defined by the Average silhouette width or the
Calinski-Harabasz index by setting the Optimal Method option. CoDaPack provides plots
of the Average silhouette width and the Calinski-Harabasz index and stores only the best
solution in the data file as Group.

The Group variable is later used in the Groups box of the Statistics >Compositional
statistics summary menu to compute the cluster geometric means.

Fig. 7: Mosaic plots are not currently supported by CoDaPack. The data can be exported
to Excel and read with the user’s favourite statistical software. Advanced users can run
script files of the R statistical software (R Core Team, 2016) through the CoDaPack
developer menu. The menu File »>Configuration »Show Dev Menu activates this function.
Then the Development > Model S4 menu allows the user to select the categorical variable
for the horizontal axis in Selected data X, and for the vertical axis in Selected data Y. One
must then select a plain text file with the instructions in Appendix 3.

Fig. 8: The Graphs »Boxplot menu produces the boxplot, after introducing the firm age
into the Selected Variables box, with Options »>Draw mean >None and the cluster
variable for separated boxplots in the Groups box.

Fig. 9: The Graphs »Boxplot menu produces the boxplot, after introducing the same
pairwise log-ratios constructed for Fig. 2 into the Selected Variables box, with
Options »Draw mean »>None and the categorical variable for separated boxplots in the
Groups box.

Once transformed, pairwise log-ratios can be treated with standard statistical methods.
Thus, for the purpose of descriptive statistical analysis the menu Statistics »Classical
statistics summary has to be used instead of the menu Statistics »Compositional statistics
summary.

Fig. 10: The Graphs >Scatterplot2D/3D menu produces scatterplots by introducing two
numeric variables in the Selected data box. The variable entered first appears in the
horizontal axis.

Table 7: Linear regression with pairwise log-ratios is not currently supported by
CoDaPack. The data can be exported to Excel and read with the user’s favourite statistical
software. Advanced users can run script files of the R statistical software (R Core Team,
2016) through the CoDaPack developer menu. The menu File >Configuration »Show
Dev Menu activates this function. Then the Development > Model S4 menu allows the
user to select all the predictor variables in Selected data X, and all the dependent log-
ratios constructed for Fig. 2 in Selected data Y. Variables in each box must be in the same
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order as in the data file. One must then select a plain text file with the instructions in
Appendix 4.

If stored as categorical, binary predictor variables have beforehand been coded as 0 and
1 (Data >Manipulate »>Change Categorical Label menu) and then declared as numeric in
the Data »Manipulate >Categorical to Numeric menu.

Appendix 3: R script file for mosaic plots

# R script for mosaic plots with Menu S4.

# Enter one categorical variable for the horizontal axis
# in "Selected data X"

# and one for the vertical axis in "Selected data Y".

generateFileName <- function (candidateName) {
name = candidateName
nameFile = paste (name, ".svg", sep = "")

while (file.exists (nameFile)) {
name = paste(name, "c", sep = "")
nameFile = paste (name, ".svg", sep = "")}
return (nameFile) }

graphnames <- list()

name <- generateFileName (paste (tempdir (), "Mosaic plot", sep = "\\"))

svg (name)

plot (as.factor (as.matrix (X)) ,as.factor (as.matrix(Y)),
xlab=colnames (X), ylab=colnames (Y))

dev.off ()

graphnames[1l] <- name

cdp _res = list(
'text' = unlist(list (paste("MOSAIC PLOT"))),
'graph' = graphnames)

Appendix 4: R script file for linear regression models

# Script for standard linear regression modelling with Menu S4.
# Enter all dependent log-ratios in "selected data Y"
# and all predictor variables in "selected data X"

LM <- Im(as.matrix(Y)~as.matrix (X))
cdp_res list('text'=list(

paste ("LINEAR REGRESSION"),
paste (capture.output (summary (LM)))))



