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Modelling Complex Survey Data Using R,

SAS, SPSS and Stata: A Comparison

Using CLSA Datasets
by Hon Yiu So, Urun Erbas Oz, Lauren Griffith, Susan Kirkland, Jinhua Ma, Parminder Raina,

Nazmul Sohel, Mary E. Thompson, Christina Wolfson and Changbao Wu

Abstract The R software has become popular among researchers due to its flexibility and open-source
nature. However, researchers in the fields of public health and epidemiological studies are more
customary to commercial statistical softwares such as SAS, SPSS and Stata. This paper provides a
comprehensive comparison on analysis of health survey data using the R survey package, SAS, SPSS
and Stata. We describe detailed R codes and procedures for other software packages on commonly
encountered statistical analyses, such as estimation of population means and regression analysis,
using datasets from the Canadian Longitudinal Study on Aging (CLSA). It is hoped that the paper
stimulates interest among health science researchers to carry data analysis using R and also serves as
a cookbook for statistical analysis using different software packages.
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1. Introduction

Health-care researchers use survey data to evaluate the prevalence rates of particular diseases in a
population, to establish association and causation among important health factors and measures, and
to inform the creation and implementation of new health policies. For example, the goal of the Cana-
dian Longitudinal Study of Aging (CLSA) is to facilitate vital research on healthy aging with impact,
to investigate health evidence and to propose policies for aging Canadians (Raina et al. (2019)).

As recognized in the literature (Damico (2009); Lumley (2010)) and used by researchers from
many scientific fields, R is an open-source and powerful statistical software with high capabilities in
data manipulation and high potential for different types of presentation. In recent years, the devel-
opment of RStudio, one of R’s graphic user interfaces, has facilitated use of the R program to analyze
data and to visualize results. However, the R program still has not become widely adopted as the
preferred statistical platform in the fields of public health and epidemiological studies. This is partly
due to the lack of appropriate R codes and examples in publicly available technical documents pre-
sented in a systematic manner, and the concerns on the results as compared to those from established
commercial software packages. The unawareness of similarities and differences between R and ex-
isting commercial software packages makes researchers reluctant to shift to using R as their primary
statistical software.

The main objective of this paper is to describe the main steps required to model complex survey
data using R, SAS, SPSS and Stata, with particular attention to dataset preparation, data importation
and detailed statistical analyses using the CLSA datasets, and to produce the finite population esti-
mates commonly reported by health researchers. The secondary objective of the paper is to provide
R examples for the analyses and to promote R as a preferred platform for researchers in related fields.

This article compares estimates and standard errors from various statistical procedures imple-
mented by selected proprietary statistical packages, namely SAS, SPSS and Stata, with those of the
survey package in R, using data from the Canadian Longitudinal Study on Aging (CLSA). We com-
pute the standard errors by the Taylor series linearization with the variance estimator of the Hansen-
Hurwitz estimator (Lumley (2004)) adjusted by the finite population correction factor, which is the
default option for all the survey packages we compared.

The rest of the paper is organized as follows. In Section 2, we provide the rationale for using sam-
pling weights in the statistical analysis of survey data. In Section 3, we briefly describe the sampling
framework of the CLSA. We provide codes for data import and preparation for survey analysis in Sec-
tion 4. We compare the syntax, estimates and standard errors of survey summary procedures across
different survey packages in Section 5. For regression analyses, we recommend to use the analytic
weights, and provide the detailed descriptions in Section 6. In Section 7, we discuss subpopulation
(i.e., domain) analysis in the survey context. Lastly, we provide some concluding remarks in Section
8.

2. Preliminaries of survey sampling

The purpose of statistical analyses in survey sampling is to make inferences about the target finite
population from the information available in a survey sample. To obtain the sample, we select a sub-
set of units from the population through a known sampling scheme and measure variables of interest
for all selected units. The following picture illustrates the relationship between the population and
the sample and the connections through sampling and inference.

Population Sample

Sampling

Inference

Most real world survey samples are selected by a without-replacement sampling method with un-
equal inclusion probabilities. The general estimation theory is built based on the Horvitz-Thompson
estimator (Horvitz and Thompson (1952)) using the first order inclusion probabilities. Variance esti-
mation typically requires second order inclusion probabilities, which are often unavailable in practice
for a given survey dataset. Two other major features of survey designs, namely, stratification and
clustering, requires additional details for point and variance estimation. Variance formulas under
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with-replacement sampling methods based on the Hansen-Hurwitz estimator (Hansen and Hurwitz
(1943)) have much simpler forms and are easy to implement. Even if the original survey sample is
selected without-replacement, it is common practice for survey data analysis to treat the sample as if
the units are selected with-replacement for the purpose of variance estimation. The resulting variance
estimators are valid if the sampling fractions of the original survey sample are small and the variance
estimates become more conservative otherwise; see Lohr (2010) and Wu and Thompson (2020) for
further details.

In what follows, we present theoretical details for stratified single-stage sampling, which is the
sampling design used by CLSA (Canadian Longitudinal Study on Aging (2011); Raina et al. (2019)).
Under a stratified sampling design, the population is (sometimes naturally) divided into non-overlapping
subpopulations called “strata”. Within each stratum, individual units are selected based on a proba-
bility sampling design. The following notations are used for stratified sampling.

Notation Meaning

H the number of strata
Sh the set of sampled units from stratum h, h = 1, · · · , H

S the pooled sample, S =
H⋃

h=1
Sh

Nh the total number of units in stratum h, h = 1, · · · , H

N the total number of units in the population, N = ∑
H
h=1 Nh

nh the sample size for stratum h, h = 1, · · · , H

n the overall sample size, n = ∑
H
h=1 nh

πih
sample inclusion probability of unit i in stratum h

πihi′h
joint inclusion probability of units i and i′ in stratum h

wih
the stratum design weight, wih

= π−1
ih

yih
the value of the study variable y for unit i in stratum h

xxxih
the value of covariates xxx for unit i in stratum h

The survey dataset can be represented by {(yih
, xxxih

, wih
), ih ∈ Sh, h = 1, · · · , H}.

Estimation of population means

In survey sampling, basic inferential procedures are developed for the estimation of finite population
means. For the study variable y, the population mean under stratification is given by

µy =
1

N

H

∑
h=1

Nh

∑
ih=1

yih
. (1)

Estimation of a disease prevalence is a special case of estimating a population proportion with a
binary study variable y. The design-unbiased Horvitz-Thompson estimator of µy is given by

µ̂yHT =
1

N

H

∑
h=1

∑
ih∈Sh

wih
yih

. (2)

The stratum design weight wih
= π−1

ih
is often interpreted as the number of units in the popula-

tion represented by the unit ih in the sample (Lohr (2010); Wu and Thompson (2020)). The Horvitz-

Thompson estimator for the population total Ty = ∑
H
h=1 ∑

Nh

ih=1 yih
is given by T̂yHT = ∑

H
h=1 ∑ih∈Sh

wih
yih

,

which is also called the expansion estimator. The design weight wih
is also called the inflation weight.

The population size N is sometimes unknown to data users. An unbiased estimator of N is given
by N̂ = ∑

H
h=1 ∑ih∈Sh

wih
. The resulting estimator of µy is the so-called Hájek estimator given by

µ̂yH = T̂yHT/N̂.

The theoretical design-based variance of the Horvitz-Thompson estimator given in (2) involves
both the first-order and the second-order sample inclusion probabilities πih

and πihi′h
. Under stratified

sampling, the stratum samples Sh, h = 1, · · · , H are independent. The general theoretical variance
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formula is given by

Var(µ̂yHT) = N−2
H

∑
h=1

Var

(
∑

ih∈Sh

yih

πih

)

= N−2
H

∑
h=1




Nh

∑
ih=1

Nh

∑
i′h=1

(
πihi′h

− πih
πi′h

) yih

πih

yih

πih


 .

The conventional unbiased variance estimator for the Horvitz-Thompson estimator is given by

V̂ar(µ̂yHT) = N−2
H

∑
h=1


 ∑

ih∈Sh

∑
i′h∈Sh

πihi′h
− πih

πi′h

πihi′h

yih

πih

yih

πih


 . (3)

In practice, complex survey datasets, such as the CLSA datasets used in this paper, usually do not
provide the joint inclusion probabilities πihi′h

which are required for computing the variance estimator

given in (3). Most statistical software packages for survey data analyses use approximate variance
estimators to bypass this difficulty.

When sampled units are drawn with-replacement, with selection probabilities zih
, ih = 1, · · · , Nh

for each selection, the Hansen-Hurwitz estimator (Hansen and Hurwitz (1943)) of µy has the same
algebraic form of the Horvitz-Thompson estimator if we let πih

= nhzih
. The unbiased variance

estimator for the Hansen-Hurwitz estimator is given by

V̂0 = N−2
H

∑
h=1

1

nh(nh − 1) ∑
ih∈Sh

(
nhwih

yih
− ∑

ih∈Sh

wih
yih

)2

. (4)

The variance estimator V̂0 does not involve second-order inclusion probabilities and provides a good
approximation to the variance estimator given in (3) if the sampling fractions fh = nh/Nh are small
for the original without-replacement survey design. When the sampling fractions are not small, an
ad hoc adjustment to (4) is to apply the finite population correction factor 1 − fh within each stratum.
The resulting variance estimator is given by

V̂ = N−2
H

∑
h=1

1 − fh

nh(nh − 1) ∑
ih∈Sh

(
nhwih

yih
− ∑

ih∈Sh

wih
yih

)2

. (5)

The variance estimator V̂ given in (5) is exactly design-unbiased for stratified simple random sam-
pling. For general stratified unequal probability sampling, the performance of V̂ varies depending
on the original survey design. There exist other approximate variance formulas not involving second-
order inclusion probabilities and performing better for certain designs. See, for instance, Haziza et al.
(2008) for further details. The variance estimator V̂ is the default option for most survey packages,
including R, SAS, SPSS and Stata.

Stratified multi-stage sampling can use approximate variance estimators similar to V̂ if sampling
fractions for the first stage clusters are small within each stratum. For cases where N is unknown
and the Hájek estimator µ̂yH is used, the variance estimator V̂ given in (5) needs to be modified with

N being replaced by N̂ and the study variable yih
being substituted by the residual variable eih

=
yih

− µ̂yH for computing the variance estimator. Further details can be found in Wu and Thompson
(2020).

Regression analysis

Linear regression analysis and logistic regression analysis are commonly conducted by researchers
in health sciences. Survey weighted regression analysis focuses on finite population regression coeffi-
cients and also provides valid results for the model parameters under the assumed regression model.
For simplicity of notation, we assume that the covariates x contain 1 as the first component and the
regression model has an intercept. The finite population regression coefficients βββN are the solution to
the so-called census estimating equations,

UN(βββ) =
H

∑
h=1

Nh

∑
ih=1

xxxih

{
yih

− µ(xxxih
, βββ)
}
= 0 , (6)
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where µ(xxxih
, βββ) = E(yih

| xxxih
) is the mean function under the assumed regression model. For linear

regression analysis, we have µ(xxx, βββ) = xxx′βββ; for logistic regression analysis where y is a binary variable,
we have

µ(xxx, βββ) = E(y | xxx) = P(y = 1 | xxx) =
exp(xxx′βββ)

1 + exp(xxx′βββ)
.

The survey weighted estimator of βββN , denoted as β̂ββN , is the solution to the survey weighted
estimating equations,

Un(βββ) =
H

∑
h=1

∑
ih∈Sh

wih
xxxih

{
yih

− µ(xxxih
, βββ)
}
= 0 . (7)

Under the linear regression model, the estimator β̂ββN has a closed form expression. Under the logistic

regression model, it requires an iterative computational procedure to find the solution β̂ββN . The vari-

ance estimator for β̂ββN is derived based on the theory of estimating equations and has the well-known
sandwich form (Binder (1983)),

V̂ar(β̂ββN) =
{

Hn(β̂ββN)
}−1

V̂
{

Un(β̂ββN)
}{

H′
n(β̂ββN)

}−1
, (8)

where Hn(βββ) = ∂Un(βββ)/∂βββ and V̂{Un(β̂ββN)} is the estimated variance-covariance matrix of the

Horvitz-Thompson estimator Un(βββ) = ∑
H
h=1 ∑ih∈Sh

wih
gih

, with gih
= xxxih

{yih
− µ(xxxih

, βββ)} and βββ being

replaced by β̂ββN for enumerations. The variance estimator V̂ given in (5) is used again as the default
option for most survey software packages on regression analysis. With the vector form of gih

, the
estimator of the variance-covariance matrix is given by

V̂
{

Un(β̂N)
}
=

H

∑
h=1

1 − fh

nh(nh − 1) ∑
ih∈Sh

(
nhwih

gih
− ∑

ih∈S

wih
gih

)(
nhwih

gih
− ∑

ih∈S

wih
gih

)′
. (9)

Chapter 7 of Wu and Thompson (2020) contains detailed discussions on regression analysis using
survey data.

In survey sampling, estimation of regression coefficients or other parameters related to a model
is often referred to as analytic use of survey data. It is apparent from the estimating equation system
given in (7) and the sandwich variance estimator specified in (9) that rescaling the design weights

wih
by a constant does not change the point estimator β̂ββN or the variance estimator. Survey agencies

sometimes provide the so-called analytic weights as part of the survey datasets. These weights are
rescaled from the original design weights such that the sum of the analytic weights equals to the
sample size.

3. Sampling design of the CLSA

The Canadian Longitudinal Study on Aging (CLSA) uses a stratified single-stage sampling design
and has a large sample of 51,338 Canadian residents aged 45-85 years at baseline. Respondents in the
initial sample are to be followed in subsequent survey waves for at least 20 years or until death or
loss to follow-up. There are two types of respondents in the sample:

1. CLSA Tracking cohort, which has a target size of 20,000 people from across the 10 Canadian
provinces;

2. CLSA Comprehensive cohort, which aims to have 30,000 people living within 25-50 km of one
of the 11 Data Collection Sites (DCS) across 7 Canadian provinces.

Respondents in both cohorts are surveyed through telephone for a common set of baseline ques-
tions. Respondents in the comprehensive cohort are required to visit one of the DCSs to take ad-
ditional measurements for key health related variables. Further details on the CLSA survey design
and sampling procedures as well as measurements collected for each respondent can be found in
Canadian Longitudinal Study on Aging (2011) and Raina et al. (2019).

The geographic variables are the stratum indicator variables for the original CLSA survey design.
The variables are namely GEOSTRAT_TRM for the tracking cohorts, GEOSTRAT_COM for the comprehensive
cohorts, and GEOSTRAT_CLSAM for the pooled dataset of both cohorts. Researchers may also consider
to stratify further using gender, age groups, education level, etc. We do not consider stratification
beyond the geographic variables in this paper.
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4. Data preparation and survey design declaration

The demonstrations presented in this paper focus on the datasets from the CLSA. A comma-separated
values (.csv) file is available for a CLSA dataset with the variable name provided in the first row. Steps
for importing the dataset with different software packages are described below. The main dataset we
use is from the tracking cohort with the strata variable GEOSTRAT_TRM as well as the survey weight
variable, WGHTS_INFLATION_TRM.

R preparation

In R, the command read.csv is used for importing datasets from CSV files:

CLSAData <- read.csv("[Path]/CLSARealExample.csv", header=TRUE, sep = ",")

Then, we can specify the age groups and declare the survey design with the package survey:

library (survey)

CLSAData$StraVar <- CLSAData$GEOSTRAT_TRM

CLSA.design<- svydesign( ids= ~ entity_id, strata = ~ StraVar,

weights = ~ WGHTS_INFLATION_TRM, data= CLSAData, nest =TRUE )

The option weights specifies the sampling weights. We use the inflation weights for tracking co-
hort with name "WGHTS_INFLATION_TRM". The analyses of different cohorts would have different
weight variables: for analysis involving comprehensive cohort, the label for the inflation weights
is "WGHTS_INFLATION_COM," and the label for the strata variable is "GEOSTRAT_COM"; for analysis involv-
ing combined cohort, the label for the inflation weights is "WGHTS_INFLATION_CLSAM," and the label for
the strata variable is "GEOSTRAT_CLSAM."

Most proprietary statistical packages would assume single PSU strata to have no contribution to
the variance by default (Bruin (2011)). We would add the following option:

options(survey.lonely.psu = "certainty")

which means the program will ignore the PSUs with single observations during variance calculation.
If there is a stratum with only one sampled PSU, the program would ignore the stratum when com-
puting the estimated variance. The option would not impact the results if all the strata have more
than one sampled PSU.

SAS preparation

Here is how to import the CSV file as a SAS dataset. This step is skipped if one already has the CLSA
datasets in SAS format. We do not need to declare the survey design at this stage as we will specify
the design during data analysis.

PROC IMPORT datafile="[Path]/CLSARealExample.csv"

out=CLSAData dbms=csv replace;

GETNAMES=YES; DATAROW=2; guessingrows=max ;

RUN;

By default, SAS will ignore the PSUs with single observations during variance calculation.

SPSS preparation

In SPSS, readers can import the CLSA datasets by the user interface: "File" → "Import Data" → "CSV
Data" → select the datafile and click "Open". Then follow the instruction on the screen and click "Ok".

To create the stratum variable, Transform → Compute Variable → Type "StraVar" under "Target
Variable" and "WGHTS_GEOSTRAT_TRM" under "Numeric Expression" → click: "Type & Labels" and se-
lect "String" in the "Type" panel.

We then declare the survey design by clicking "Analyze" → Complex Samples → Prepare for

Analysis → click "Create a plan file" and choose a location and name as CLSADesign.csaplan

→ "Next". Under Strata, select the variables "StraVar"and select "WGHT_INFLATION_TRM" under "Sam-
pling Weight" and accept the default settings.
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By default, SPSS will ignore the PSUs with single observations during variance calculation.

Stata preparation

In Stata, we need to enter the following code to import the CSV file data:

import delimited [Path]/CLSARealExample.csv

To specify the sampling design, we define the stratum variables as WGHTS_GEOSTRAT_TRM and declare
the survey design. Similar to the R program, we assume that strata with a single unit have no contri-
bution to the variance estimation, so we put "certainty" in "singleunit()."

generate StraVar = GEOSTRAT_TRM

svyset entity_id, strata(StraVar) weight(WGHTS_INFLATION_TRM) vce(linearized)

singleunit(certainty)

The option “singleunit(certainty)” means the program will ignore the strata with single observa-
tions during variance calculation. Again, this option may not be the best one as it can underestimate
the uncertainty.

5. Estimation of descriptive population parameters

We list several standard procedures of the complex survey data and compare the standard errors
based on Taylor-series linearization across different packages.

Estimation of frequencies

The variable ENV_AFRDWLK_MCQ represents the CLSA survey question: "People would be afraid to
walk alone after dark in this area." If we want to estimate the total number of people in the study
population who agree or disagree about the statement, we can use the following sets of codes to
create tables of frequencies with standard errors.

R:

svytotal( ~(ENV_AFRDWLK_MCQ1), design= CLSA.design)

SAS:

PROC SURVEYFREQ data= CLSAData ;

TABLE ENV_AFRDWLK_MCQ1;

strata GEOSTRAT_TRM ;

weight WGHTS_INFLATION_TRM;

RUN;

SPSS:

Click "Analyze" → "Complex Samples" → "Frequency..." → Browse and select the
CLSADesign.csaplan created. → Click "Next" and import a variable (ENV_AFRDWLK_MCQ) → Click
"Statistics..." → select "Population size" and "Standard error" → Click "Continue" → Click "OK".

Stata:

svy linearized : tabulate ENV_AFRDWLK_MCQ, count se ci stubwidth(20) format(%10.0g)

Results comparison
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ENV_AFRDWLK_MCQ R SAS SPSS Stata
Population Est. Total SE Total SE Total SE Total SE

Strongly Agree 8614 2713 8614 2713 8614 2713 8614 2713
Agree 46718 6493 46718 6493 46718 6493 46718 6493

Disagree 296956 12702 296956 12702 296956 12702 296956 12702
Strongly Disagree 137300 11005 137300 11005 137300 11005 137300 11005

Missing 29311 5687 29311 5687 29311 5687 29311 5687

Note: The total of the population estimates from the table above is much smaller that the CLSA
study population. It is because the dataset used for illustration is only a subset of the CLSA dataset.
The actual dataset should give much larger population totals.

Estimation of population means

In CLSA, the variables HWT_DHT_M_TRM and HWT_WGHT_KG_TRM represent the self-reported body height
(in meter) and body weight (in kilogram), respectively. To estimate the population averages of height
and weight of the target population, we can apply the following sets of code to create tables of mean
estimates with standard errors.

R:

svymean( ~ HWT_DHT_M_TRM+HWT_WGHT_KG_TRM , CLSA.design )

SAS:

PROC SURVEYMEANS data= CLSAData ;

TABLE ENV_AFRDWLK_MCQ1;

strata GEOSTRAT_TRM ;

weight WGHTS_INFLATION_TRM;

RUN;

SPSS:

Click "Analyze" → "Complex Samples" → "Descriptive..." → Browse and select the
"CLSADesign.csaplan" → Click "Continue" and enter variables "HWT_DHT_M_TRM" and "HWT_WGHT_KG_TRM"
to the "Measures:" panel → click "Statistics..." → select "Mean" and "Standard error" → click "Con-
tinue" → click "OK".

Stata:

svy linearized : mean HWT_DHT_M_TRM HWT_WGHT_KG_TRM

Results comparison

Variable Estimate R SAS SPSS Stata

HWT_DHT_M_TRM Mean 1.6791 1.6791 1.6791 1.6791
SE 0.0037 0.0037 0.0037 0.0037

HWT_WGHT_KG_TRM Mean 97.2682 97.2682 97.2682 97.2682
SE 19.9207 19.9207 19.9207 19.9207

Estimation of ratios of population means

We created a variable HWT_DHT_M_TRM_sq, which is the square of the self-reported height (in meters).
Suppose we want to estimate the ratio of the population mean of self-reported body weight and the
population mean of self-reported boy height (squared), the estimate is computed as

∑i∈S wi(HWT_WGHT_KG_TRMi)

∑i∈S wi(HWT_DHT_M_TRM_sqi)
,

where wi is the survey weight and S is the set of sampled units.
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R:

svyratio( numerator= ~HWT_WGHT_KG_TRM, denominator = ~ HWT_DHT_M_TRM_sq, design= CLSA.design )

SAS:

PROC SURVEYMEANS data= CLSAData ratio;

var HWT_WGHT_KG_TRM HWT_DHT_M_TRM_sq;

ratio HWT_WGHT_KG_TRM / HWT_DHT_M_TRM_sq ;

strata GEOSTRAT_TRM ;

weight WGHTS_INFLATION_TRM;

RUN;

SPSS:

Click "Analyze" → "Complex Samples" → "Ratios..." → Browse and select the "CLSADesign.csaplan"
→ Click "Continue" and enter variables "HWT_WGHT_KG_TRM" and "HWT_DHT_M_TRM_sq" to the the "Nu-
merators" and "Denominator" panels, respectively → Click "Statistics..." → Select "Standard error" →
Click "Continue" → Click "OK".

Stata:

svy linearized : ratio (HWT_WGHT_KG_TRM/HWT_DHT_M_TRM_sq)

Results comparison

Package R SAS SPSS Stata
Estimate 34.4074 34.4074 34.4074 34.4074

SE 7.0573 7.0573 7.0573 7.0573

Note: We need to be aware that the estimate of the ratio of two population means is conceptually
different from the estimate of the population mean of the ratio of two variables. For the example
discussed in this section, the latter is the estimate of the population mean of BMI and is given by

∑
i∈S

wi
HWT_WGHT_KG_TRMi

HWT_DHT_M_TRM_sqi
.

Estimation of population quantiles

Let Fy(t) = N−1
∑

H
h=1 ∑

Nh

i=1 I(yhi ≤ t) be the finite population distribution function, where I(·) is the
indicator function. The 100pth population qunatile with p ∈ (0, 1) is defined as

Q(p) = F−1
y (p) = inf{t | Fy(t) ≥ p} .

Suppose we want to estimate the population quantiles of the self-reported body weight and body
height (HWT_WGHT_KG_TRM, HWT_DHT_M_TRM). The population median corresponds to the 50% quantile.
The following codes can be used.

R:

Quant.Est<-svyquantile( ~ HWT_DHT_M_TRM+HWT_WGHT_KG_TRM ,

quantile=c(0.025,0.05,0.1,0.5, 0.9,0.95, 0.975),

alpha=0.05, interval.type="Wald",design= CLSA.design,

ties=c("rounded"), ci= TRUE, se=TRUE );

Quant.Est; SE(Quant.Est);
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SAS:

PROC SURVEYMEANS data= CLSAData QUANTILE= (0.025 0.05 0.1 0.5 0.9 0.95 0.975) NONSYMCL;

VAR HWT_DHT_M_TRM HWT_WGHT_KG_TRM ;

STRATA GEOSTRAT_TRM ;

WEIGHT WGHTS_INFLATION_TRM;

RUN;

There is no formal procedure available to produce quantile estimates and their standard errors in
the SPSS and Stata packages.

Results comparison

HWT_DHT_M_TRM HWT_WGHT_KG_TRM
Quantile R SAS R SAS

Estimate 0.025 1.5125 1.5125 50.0447 50.0447
0.05 1.5311 1.5311 53.1131 53.1131

0.1 1.5552 1.5552 56.4540 56.4540
0.5 1.6637 1.6637 75.4911 75.4911
0.9 1.7859 1.7859 96.7621 96.7621

0.95 1.8164 1.8164 107.0132 107.0132
0.975 1.8443 1.8443 116.2338 116.2338

SE 0.025 0.0032 0.0070 1.0307 1.0311
0.05 0.0051 0.0060 0.6963 0.7282

0.1 0.0037 0.0050 0.6569 0.7594
0.5 0.0056 0.0054 0.8827 0.8977
0.9 0.0074 0.0075 1.9540 1.7442

0.95 0.0092 0.0069 2.1876 2.1833
0.975 0.0132 0.0094 5.2909 3.9915

For the standard error (SE) estimation, both R and SAS first construct 95% confident intervals (CIs)
by the Woodruff’s method (Woodruff (1952), and then compute the standard errors from the division
of the CI lengths by td f ,0.025, the 97.50th percentile of the t distribution with degrees of freedom, d f ,
which is determined by the survey data and the survey design. For CLSA, the degrees of freedom
is the number of observations minus the number of strata. If the sample size is relatively large, we
can simply replace td f ,0.025 by z0.025, the 97.50th percentile from the standard normal distribution.
The difference in standard errors is due to different implementation of Woodruff interval. Let y(1) ≤
y(2) ≤ · · · ≤ y(n) denote the sample order statistics for the variable Y. The 100pth population quantile
estimate is computed as

Q̂(p) =





y(1) if p ≤ F̂y(y(1))

y(k) +
p−F̂y(y(k))

F̂y(y(k+1))−F̂y(y(k))
(y(k+1) − y(k)) if F̂y(y(k)) < p ≤ F̂y(y(k+1))

,

where F̂y(t) = N̂−1 ∑
H
h=1 ∑i∈Sh

whi I(yhi ≤ t) is the estimated cumulative distribution for Y and

N̂ = ∑
H
h=1 ∑i∈Sh

whi. The variance of the estimated distribution function F̂y(t) at t = Q(p) can

be estimated as V̂(F̂y(Q̂(p))) = N̂−2 ∑
H
h=1

nh
nh−1 ∑i∈Sh

(ehi − ēh·)
2, where ehi = whi I(yhi ≤ Q̂(p)) −

F̂y(Q̂(p)), ēh· = n−1
h ∑i∈Sh

ehi. The CI for 100pth quantile can be obtained as (Q̂( p̂L), Q̂( p̂U)). In R, p̂L

and p̂U are implemented as

( p̂L, p̂U) =

(
p − td f ,α/2,

√
V̂(F̂y(Q̂(p))), p + td f ,α/2,

√
V̂(F̂y(Q̂(p)))

)
,

while in SAS, p̂L and p̂U are implemented as

( p̂L, p̂U) =

(
F̂y(Q̂(p))− td f ,α/2,

√
V̂(F̂y(Q̂(p))), F̂y(Q̂(p)) + td f ,α/2,

√
V̂(F̂y(Q̂(p)))

)
,

which explains the differences in the SE estimates.

One can observe that standard errors for the extreme quantiles are usually larger while the errors are
smaller for quantiles around the median. This is because the data are sparser around the extreme
quantiles and the sampling distributions of extreme quantile estimators are often skewed.
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Estimation of odds ratios, relative risks and risk differences

Suppose we want to describe the population relationship between two binary variables, say whether
experiencing dry mouth in the past 12 months (the variable ORH_EXP_DRM_MCQ) and sex (the variable
SEX_ASK_TRM). The following codes can be used to produce estimates of odds ratios, relative risks and
risk differences.

R There is no formal support from the R survey package to produce unadjusted odds ratios, relative
risks, risk differences, nor the related confidence intervals. For the relative risk, there is only one
example on page 103 of the manual of R survey(Lumley (2018)). The following R codes can produce
results similar to other survey packages.

LogisticReg4.OR<-svyglm(ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM ,

family=quasibinomial(link="logit"), design=CLSA.design)

exp(coef(LogisticReg4.OR)[2]) ## odds ratio

exp(confint(LogisticReg4.OR)[2,]) ## confidence interval

LogisticReg4.RR<-svyglm(ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM ,

family=quasibinomial(link="log"), design=CLSA.design)

exp(coef(LogisticReg4.RR)[2]) ## relative risk

exp(confint(LogisticReg4.RR)[2,]) ## confidence interval

LogisticReg4.RD<-svyglm(ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM ,

family=quasibinomial(link="identity"), design=CLSA.design)

coef(LogisticReg4.RD)[2] ## risk difference

confint(LogisticReg4.RD)[2,] ## Confidence interval

SAS We can obtain the unadjusted odds ratios, relative risks and risk differences by specifying the
options, OR and RISK in the table statement. We can specify the order of the categorical variables by
the Proc Format. Usually, SAS only provide confidence intervals instead of standard errors for the
estimates.

PROC Format;

VALUE Bin 1 = "1:Yes" 0 = "2:No" ;

VALUE $genB "F" = "2:Female" "M" = "1:Male";

run;

PROC SURVEYFREQ data=CLSAData ORDER= FORMATTED ;

TABLE SEX_ASK_TRM * ORH_EXP_DRM_MCQ / OR RISK ;

STRATA GEOSTRAT_TRM;

WEIGHT WGHTS_INFLATION_TRM;

format ORH_EXP_DRM_MCQ Bin. SEX_ASK_TRM $genB. ;

RUN;

SPSS Analyze → Complex Samples → Crosstabs... → Select the file "CLSADesign.csaplan" in the
Plan panel → click "Continue" → select the corresponding variables to the "Rows", "Factor" and target
variable to the "Column" panels → click "Statistics..." → select "Confidence interval" and "Standard
error" → click "Odds Ratios", "Risk difference" and "Relative risk" → click "Continue" → click "Con-
tinue" → click "OK".

Stata There is no formal support from Stata survey package to produce unadjusted odds ratios, rel-
ative risks and risk differences and the confidence limits. However, the following codes can produce
results similar to other survey packages.

Odds ratio:

svy linearized: logistic ORH_EXP_DRM_MCQ SEX_ASK_TRM

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM, fam(binomial) link(log) eform

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM, fam(binomial) link(identity)

Results comparison
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Variable: ORH_EXP_DRM_MCQ R SAS SPSS Stata
Odds ratio (M vs F) 0.6441 0.6441 0.6441 0.6441
95% lower limit 0.4088 0.4085 0.4085 0.4085
95% upper limit 1.0149 1.0155 1.0155 1.0155

Relative risk (M vs F) 0.7111 0.7111 0.7111 0.7111
95% lower limit 0.4971 0.4968 0.4968 0.4968
95% upper limit 1.0173 1.0178 1.0178 1.0178

Risk difference (M vs F) -0.0765 -0.0765 -0.0765 -0.0765
95% lower limit -0.1527 -0.1528 -0.1528 -0.1528
95% upper limit -0.0003 -0.0002 -0.0002 -0.0002

Note: The estimates of odds ratios, relative risks and risk differences obtained by these procedures
describe the relationship of the target variables and exposure groups in the population. The binomial
regressions used here do not describe a model for the variables in the population. Thus, the results
in this section may be different from the logistics regression results in the later session. The reason
is due to the use of “analytic weights", which are often rescaled within each stratum under stratified
sampling.

Estimation of covariance

If we are interested in estimating the population variance and population covariance of the self-
reported body height and body weight (HWT_DHT_M_TRM and HWT_WGHT_KG_TRM), the following codes
can be used.

R

print(svyvar( ~ HWT_DHT_M_TRM+HWT_WGHT_KG_TRM , CLSA.design), covariance=TRUE)

Result

Statistics Estimate SE
Var ( HWT_DHT_M_TRM) 7.5974E-03 4.0000E-04
Var (HWT_WGHT_KG_TRM) 1.5382E+05 1.5246E+05
Cov (HWT_DHT_M_TRM,HWT_WGHT_KG_TRM) -1.3799E+00 2.0704E+00

Note 1: There are no formal procedures for estimation of population variance and covariance in
SAS, SPSS or Stata.

Note 2: The population covariance is a descriptive parameter on the relationship between the two
target variables in the population. Estimation of a population covariance is a different task than
regression analysis to be presented in the next section.

6. Analytic weights and estimation of model parameters

Analytic use of survey data on estimation of model parameters has been discussed briefly in Section
2. The analytic weights, which are rescaled from the design weights (or inflation weights) with sum
equaling to the sample size, are often used. They produce the same point estimates and variance
estimates under non-stratified sampling. Under stratified sampling where strata have very different
sizes, units in some large strata, such as the province of Ontario in the CLSA datasets, have much
larger weights and observations from these large strata often dominate the analysis (Scott (2006);
Thompson (2008)). A common practice in creating analytic weights under stratified sampling is to
rescale the weights within each stratum such that the total stratum weight equals to the stratum sam-
ple size. The resulting estimates of the model parameters are not identical to the estimates using the
inflation weights but are more stable and also interpretable for the given finite population (Thompson
(2008)).

The analytic weights of the CLSA datasets are provided with the names WGHTS_ANALYTIC_***.
For the datasets from the tracking cohort, the weights are given by the variable WGHTS_ANALYTIC_TRM

and are proportional to the inflation weights but rescaled to sum to the sample size within each
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province so that their mean value is one within each province. For the datasets from the comprehen-
sive cohort, the weights are given by the variable WGHTS_ANALYTIC_COM and are proportional to the
inflation weights but rescaled to sum to sample size within the Data Collection Site (DCS) part of
each province, so that their mean value is one within that area. For the datasets from the pooled data,
the weights WGHTS_ANALYTIC_CLSAM are proportional to the inflation weights for the pooled data but
rescaled to sum to sample size within the DCS and non-DCS part of each province. Details of the
analytic weights in other datasets are provided in the CLSA technical document on sample weights
(Canadian Longitudinal Study on Aging (2011)).

The survey design can be declared similarly as in Section 4 except replacing the survey weight
with WGHTS_ANALYTIC_TRM.

For R:

CLSA.design.anly<- svydesign( ids= ~ entity_id, strata = ~ StraVar,

weights = ~ WGHTS_ANALYTIC_TRM, data= CLSAData, nest =TRUE )

For SPSS: We declare the survey design by clicking "Analyze" → Complex Samples → Prepare for

Analysis→ click "Create a plan file" and choose a location and name as CLSADesignAnyl.csaplan
→ "Next". Under Strata, select the variables "StraVar"and select "WGHT_ANALYTIC_TRM" under "Sam-
pling Weight" and accept the default settings.

For Stata:

svyset entity_id, strata(StraVar) weight(WGHTS_ANALYTIC_TRM) vce(linearized)

singleunit(certainty)

Comments on the selection of variables for analysis

It is recommended that key design variables for CLSA, such as gender, age group (45-54, 55-64, 65-
74, and 75-85), education level (low, medium, high lower, and high upper), should be included in
the initial model. The stratum indicator variables, i.e., the provinces for the tracking cohort or the
provinces crossed with individual DCS areas for the comprehensive cohort and the pooled cohorts,
may also be included. Some of these variables may be removed in the final model if it is shown that
they are not significant.

Linear regression analysis

We consider a regression model with the self-reported body height as the response variable and the
body weight as the key predictor. We also include province, sex, age group, and education level in
the initial model.

R:

LinearReg<-svyglm( HWT_DHT_M_TRM~ HWT_WGHT_KG_TRM+WGHTS_PROV_TRM1 + SEX_ASK_TRM +

Age_Grp+Education, family="gaussian", design=CLSA.design.anly)

summary(LinearReg)

SAS:

PROC SURVEYREG data=CLSAData order=formatted;

CLASS WGHTS_PROV_TRM1 Age_Grp SEX_ASK_TRM Education ;

STRATA GEOSTRAT_TRM ;

MODEL HWT_DHT_M_TRM = HWT_WGHT_KG_TRM WGHTS_PROV_TRM1 SEX_ASK_TRM Age_Grp

Education / solution ;

WEIGHT WGHTS_ANALYTIC_TRM;

STORE out=LinearReg;

ods output ParameterEstimates = MyParmEst ;

RUN;

PROC print data =MyParmEst;

FORMAT Estimate 10.9 StdErr10.9;

RUN;
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SPSS:

Analyze → Complex Samples → General Linear Model... → Select the file "CLSADesignAnyl.csaplan"
in the Plan panel → click "Continue" → select the corresponding variables to the "Dependent Vari-
able", "Factor" and "Covariate" panels → click "Statistics..." → select "Estimate" and "Standard error"
→ click "Continue"→ click "Save"→ click enter the path and file name "LinearReg.xml" under "Export
Model as XML → click "Continue" → Click "Finish".

Stata:

svy linearized : regress HWT_DHT_M_TRM HWT_WGHT_KG_TRM i.WGHTS_PROV_TRM SEX_ASK_TRM

i.Age_Grp i.Education

estimates save "[Path]\LinearReg.ster", replace

Results comparison:

R SAS SPSS Stata
Population Est. Coeff. SE Coeff. SE Coeff. SE Coeff. SE

(Intercept) 1.6188 0.0158 1.6188 0.0160 1.6188 0.0158 1.6188 0.0158
HWT_WGHT_KG_TRM -6.34E-6 3.09E-6 -6.34E-6 3.12E-6 -6.34E-6 3.09E-6 -6.34E-6 3.09E-6

SEX_ASK_TRMM 0.1247 0.0053 0.1247 0.0054 0.1247 0.0053 0.1247 0.0053
Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.0059 0.0096 0.0059 0.0097 0.0059 0.0096 0.0059 0.0096
Age_Gpr3:Age 65-74 -0.0029 0.0098 -0.0029 0.0100 -0.0029 0.0099 -0.0029 0.0098

Age_Gpr4:Age 75+ -0.0135 0.0118 -0.0135 0.0119 -0.0135 0.0118 -0.0135 0.0118
Education Levels
(rel. to Lower Education)

Medium Education 0.0056 0.0105 0.0056 0.0106 0.0056 0.0105 0.0056 0.0105
Higher Education lower 0.0094 0.0104 0.0094 0.0106 0.0094 0.0104 0.0094 0.0104
Higher Education upper 0.0186 0.0105 0.0186 0.0106 0.0186 0.0105 0.0186 0.0105

Provinces
(rel. to Alberta)

British Columbia 0.0131 0.0110 0.0131 0.0111 0.0131 0.0110 0.0131 0.0110
Manitoba 0.0073 0.0121 0.0073 0.0122 0.0073 0.0121 0.0073 0.0121

New Brunswick -0.0040 0.0128 -0.0040 0.0129 -0.0040 0.0128 -0.0040 0.0128
Newfoundland & Labrador 0.0005 0.0118 0.0005 0.0119 0.0005 0.0117 0.0005 0.0118

Nova Scotia 0.0055 0.0124 0.0055 0.0126 0.0055 0.0124 0.0055 0.0124
Ontario -0.0015 0.0114 -0.0015 0.0116 -0.0015 0.0114 -0.0015 0.0114

Prince Edward Island -0.0056 0.0126 -0.0056 0.0127 -0.0056 0.0126 -0.0056 0.0126
Quebec -0.0100 0.0106 -0.0100 0.0107 -0.0100 0.0106 -0.0100 0.0106

Saskatchewan -0.0136 0.0131 -0.0136 0.0132 -0.0136 0.0131 -0.0136 0.0131

The fitted model can be used to predict the response at a new data entry. We take the first entry of
the dataset as an example for illustration and compare the predicted height and confidence intervals.

R:

Pred1 <- predict( LinearReg, newdata= CLSAData[1,], se.fit=TRUE)

Pred1; confint(Pred1)

SAS:

PROC plm source=LinearReg ALPHA=0.05 ;

score data=CLSAData(obs=1) out=testout predicted STDERR LCLM UCLM / ilink;

run;

PROC print data=testout;

VAR predicted STDERR LCLM UCLM ;

format predicted 10.9 STDERR 10.9 LCLM 10.9 UCLM 10.9;

run;

SPSS: Open a new dataset → Utilities → Scoring Wizard → Click "Browse" and enter the corre-
sponding path and select "LinearReg.xml" → Click "Next >" → Match the variable with model fields
→ Click "Next >" → Click "Finish".
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Stata:

estimates use "[Path]\LinearReg.ster"

predict p1 if entity_id == 39511 , xb

predict se1 if entity_id == 39511 , stdp

display p1

display se1

display p1 - invnormal(0.975)*se1

display p1 + invnormal(0.975)*se1

Results comparison:

R SAS SPSS Stata
Predicted value 1.6280 1.6280 1.6280 1.6280
Standard error 0.0108 0.0109 0.0108 0.0108

95% Lower confidence limit 1.6068 1.6066 Not provided 1.6068
95% Upper confidence limit 1.6492 1.6494 Not provided 1.6492

Logistic regression analysis

In the CLSA datasets, the variable "ORH_EXP_DRM_MCQ" indicates if the respondents experienced dry
mouth in the last 12 months. We relate this variable to the age group of the respondents through a
logistic regression model. The variables sex, province and education level are also included in the
initial model as covariates.

R:

LogitReg<-svyglm( ORH_EXP_DRM_MCQ ~ WGHTS_PROV_TRM1 + SEX_ASK_TRM + Age_Grp+Education,

family=quasibinomial,design=CLSA.design.anly)

summary(LogitReg)

SAS:

PROC SURVEYLOGISTIC data=CLSAData ;

class ORH_EXP_DRM_MCQ(ref=first) WGHTS_PROV_TRM1 Age_Grp SEX_ASK_TRM Education/param=ref;

model ORH_EXP_DRM_MCQ (event='1')= WGHTS_PROV_TRM1 Age_Grp SEX_ASK_TRM Education;

strata GEOSTRAT_TRM;

weight WGHTS_ANALYTIC_TRM;

store out= LogitReg;

ods output ParameterEstimates = MyParmEst;

RUN;

PROC print data = MyParmEst;

format Estimate 10.9 StdErr 10.9;

run;

SPSS:

Analyze → Complex Samples → Logistc Regression... → Select the file "CLSADesignAnyl.csaplan"
in the Plan panel → click "Continue" → select the corresponding variables to the "Dependent Vari-
able", "Factor" and "Covariate" panels → click "Reference Category" and select "Lowest value" → click
"Statistics..." → select "Estimate" and "Standard error" → click "Continue" → Click "Save..." → Enter
"LogitReg.xml" under "Export Model as XML" → click "Continue" → click "OK".

Stata:

svy linearized: logit ORH_EXP_DRM_MCQ i.WGHTS_PROV_TRM SEX_ASK_TRM i.Age_Grp i.Education

estimates save "[Path]\LogitReg.ster", replace
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Results comparison:

R SAS SPSS Stata
Population Est. Coeff. SE Coeff. SE Coeff. SE Coeff. SE

(Intercept) -1.0106 0.5382 -1.0106 0.5435 -1.0106 0.5378 -1.0106 0.5382
SEX_ASK_TRMM -0.5274 0.2055 -0.5274 0.2076 -0.5274 0.2054 -0.5274 0.2055

Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.3921 0.3335 0.3921 0.3369 0.3921 0.3334 0.3921 0.3335
Age_Gpr3:Age 65-74 0.7467 0.3325 0.7467 0.3358 0.7467 0.3326 0.7467 0.3325

Age_Gpr4:Age 75+ 0.8633 0.4467 0.8633 0.4511 0.8633 0.4464 0.8633 0.4467
Education Levels
(rel. to Lower Education)

Medium Education -0.1388 0.3414 -0.1388 0.3448 -0.1388 0.3422 -0.1388 0.3414
Higher Education lower -0.0473 0.3428 -0.0473 0.3462 -0.0473 0.3432 -0.0473 0.3428
Higher Education upper -0.1112 0.3420 -0.1112 0.3455 -0.1112 0.3422 -0.1112 0.3420

Provinces
(rel. to Alberta)

British Columbia -0.9356 0.4639 -0.9356 0.4686 -0.9356 0.4639 -0.9356 0.4639
Manitoba -0.2682 0.4478 -0.2682 0.4522 -0.2682 0.4478 -0.2682 0.4478

New Brunswick -0.0187 0.4500 -0.0187 0.4545 -0.0187 0.4500 -0.0187 0.4500
Newfoundland & Labrador -0.4196 0.4767 -0.4196 0.4815 -0.4196 0.4731 -0.4196 0.4767

Nova Scotia 0.3213 0.4541 0.3213 0.4586 0.3213 0.4541 0.3213 0.4541
Ontario -0.2506 0.4268 -0.2506 0.4311 -0.2506 0.4268 -0.2506 0.4268

Prince Edward Island -0.4300 0.4818 -0.4300 0.4866 -0.4300 0.4818 -0.4300 0.4818
Quebec -0.4541 0.3862 -0.4541 0.3901 -0.4541 0.3862 -0.4541 0.3862

Saskatchewan -0.6365 0.4915 -0.6365 0.4964 -0.6365 0.4914 -0.6365 0.4914

The fitted model can also be used to predict the probabilities of the response categories at a new
data entry. We take the first entry of the dataset as an example for illustration and compare the
predicted probability of “YES” and confidence intervals.

R:

Pred2<- predict( LogitReg, newdata= CLSAData[1,], type= "link" , se.fit=TRUE)

plogis(Pred2[1]); plogis(confint(Pred2))

predict( LogitReg, newdata= CLSAData[1,], type= "response" , se.fit=TRUE) # for SE

SAS:

PROC plm source=LogitReg ALPHA=0.05 ;

score data=CLSAData(obs=1) out=testout predicted STDERR LCLM UCLM / ilink;

run;

PROC print data=testout;

VAR predicted STDERR LCLM UCLM ;

format predicted 10.9 STDERR 10.9 LCLM 10.9 UCLM 10.9;

run;

SPSS:

Open a new dataset → Utilities → Scoring Wizard → Click "Browse" and enter the corresponding
path and select "LogitReg.xml" → Click "Next >" → Match the variable with model fields → Click
"Next >" → Enter a value for selected probability → Click "Next >" and Click "Finish".

Stata:

estimates use "[Path]\LogitReg.ster"

predict p2 if entity_id == 39511 , xb

predict se2 if entity_id == 39511 , stdp

display invlogit(p2)

display invlogit(p2 - invnormal(0.975)*se2)

display invlogit(p2 + invnormal(0.975)*se2)
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Results comparison:

R SAS SPSS Stata

Predicted value 0.2505 0.2505 0.2505 0.2505
Standard error 0.0734 0.0741 Not provided Not provided

95% Lower confidence limit 0.1336 0.1375 Not provided 0.1345
95% Upper confidence limit 0.3944 0.4201 Not provided 0.4183

Multinomial logistic regression analysis

Multinomial logistic regression deals with nominal responses with three or more categories. Suppose
we want to investigate the relationship between current marital statuses WEA_MRTL_CURRENT_MCQ and
sex, age group, education level and province. We can use a multinomial logistic regression model
with the following codes.

R: There is no official support for multinomial regression from the R package survey.

SAS:

PROC SURVEYLOGISTIC data=CLSAData;

class WEA_MRTL_CURRENT_MCQ2 SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM /param=ref;

model WEA_MRTL_CURRENT_MCQ2 = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM /link=glogit;

strata GEOSTRAT_TRM;

weight WGHTS_ANALYTIC_TRM;

RUN;

SPSS:

Analyze → Complex Samples → Logistc Regression... → Select the file "CLSADesignAnyl.csaplan"
in the Plan panel → click "Continue" → select the corresponding variables to the "Dependent Vari-
able", "Factor" and "Covariate" panels → click "Reference Category" and select "Lowest value" → click
"Statistics..." → select "Estimate" and "Standard error" → click "Continue" → click "OK".

Stata:

svy linearized : mlogit WEA_MRTL_CURRENT_MCQ1 SEX_ASK_TRM i.Age_Grp i.Education

i.WGHTS_PROV_TRM , baseoutcome(1)

Results comparison:
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(relative to SAS SPSS Stata
1:Single) Coefficient Est. SE Est. SE Est. SE

2:Married (Intercept) 1.8405 0.7732 1.8404 0.7578 1.8404 0.7578
SEX_ASK_TRMM 0.3545 0.3015 0.3545 0.2955 0.3545 0.2955

Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.2326 0.4226 0.2326 0.4142 0.2326 0.4142
Age_Gpr3:Age 65-74 0.2151 0.4512 0.2151 0.4422 0.2151 0.4422

Age_Gpr4:Age 75+ -0.6337 0.6108 -0.6337 0.5986 -0.6337 0.5986
Education Levels
(rel. to Lower Education)

Medium Education 0.1864 0.5388 0.1864 0.5281 0.1864 0.5281
Higher Education lower 0.1275 0.5510 0.1275 0.5400 0.1275 0.5400
Higher Education upper 0.3125 0.5393 0.3125 0.5286 0.3125 0.5286

Provinces
(rel. to Alberta)

British Columbia -0.0696 0.6455 -0.0696 0.6326 -0.0696 0.6326
Manitoba -0.5858 0.5732 -0.5858 0.5637 -0.5858 0.5637

New Brunswick 0.5804 0.7378 0.5804 0.7231 0.5804 0.7231
Newfoundland & Labrador -0.0135 0.7509 -0.0135 0.7359 -0.0135 0.7359

Nova Scotia 0.3114 0.7195 0.3114 0.7052 0.3114 0.7052
Ontario -0.5085 0.5857 -0.5085 0.5739 -0.5085 0.5740

Prince Edward Island -1.2410 0.6086 -1.2410 0.5964 -1.2410 0.5964
Quebec -0.8317 0.5443 -0.8317 0.5334 -0.8317 0.5334

Saskatchewan 1.6674 1.1595 1.6690 1.1378 1.6690 1.1378

3:Others (Intercept) 0.1472 0.9537 0.1472 0.9347 0.1472 0.9347
SEX_ASK_TRMM -0.8986 0.3528 -0.8986 0.3457 -0.8986 0.3457

Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.9486 0.5433 0.9486 0.5325 0.9486 0.5325
Age_Gpr3:Age 65-74 1.2005 0.5663 1.2005 0.5550 1.2005 0.5550

Age_Gpr4:Age 75+ 1.5612 0.6868 1.5612 0.6731 1.5612 0.6731
Education Levels
(rel. to Lower Education)

Medium Education 0.4234 0.6150 0.4234 0.6027 0.4234 0.6027
Higher Education lower 0.2592 0.6259 0.2592 0.6134 0.2592 0.6134
Higher Education upper 0.3732 0.6256 0.3732 0.6131 0.3732 0.6131

Provinces
(rel. to Alberta)

British Columbia -0.3919 0.7073 -0.3919 0.6932 -0.3919 0.6932
Manitoba -0.4276 0.6639 -0.4276 0.6506 -0.4276 0.6506

New Brunswick 0.3460 0.8432 0.3460 0.8264 0.3460 0.8264
Newfoundland & Labrador -0.9291 0.8419 -0.9291 0.8251 -0.9291 0.8251

Nova Scotia 0.2144 0.7987 0.2144 0.7827 0.2144 0.7827
Ontario -0.7852 0.6684 -0.7852 0.6551 -0.7852 0.6551

Prince Edward Island -1.3250 0.7084 -1.3250 0.6943 -1.3250 0.6943
Quebec -0.6610 0.6208 -0.6610 0.6084 -0.6610 0.6084

Saskatchewan 1.1766 1.2168 1.1781 1.1939 1.1781 1.1939

Ordinal logistic regression analysis

Many variables in complex surveys are ordinal, where the response variable has a well-defined order
for the categories. Ordinal logistic regression analysis is suitable to model the relationship between
the probabilities of the cumulative categories and the key factors. Suppose we are interested in the
relationship between the response categories of ENV_AFRDWLK_MCQ: Strongly Agree (d = 1), Agree
(d = 2), Disagree (d = 3), and Strongly Disagree(d = 4) and sex and age. The cumulative logistic
regression model has the form

g(Pr(Y < d | xxx)) = αd + xxx′βββ, (for SAS)

g(Pr(Y < d | xxx)) = αd − xxx′ηηη, (for R, SPSS and Stata)

with d = 2, 3, 4, where g(·) is a link function. We usually specify g(·) as the logit function, and
the model becomes the cumulative logit model (also known as the proportional odds model). For
comparison purposes, we multiply −1 to the SAS coefficient estimates output for βββ.

R:
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summary(svyolr(formula = ENV_AFRDWLK_MCQ2 ~ SEX_ASK_TRM + Age_Grp+ Education+WGHTS_PROV_TRM,

design = CLSA.design.anly , na.action = na.omit, method = c("logistic")) )

SAS:

PROC surveylogistic data=CLSAData ;

class ENV_AFRDWLK_MCQ2(ref=first) /param=ref;

model ENV_AFRDWLK_MCQ2 = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM /clodds ;

strata GEOSTRAT_TRM;

weight WGHTS_ANALYTIC_TRM;

run;

SPSS:

Analyze → Complex Samples → Ordinal Regression... → Select the file "CLSADesignAnyl.csaplan"
in the Plan panel → click "Continue" → select the corresponding variables to the "Dependent Vari-
able", "Factor" and "Covariate" panels → click "Response Probabilities" and select "Accumulate from
lowest value of dependent variable to highest value" → click "Statistics..." → select "Estimate" and
"Standard error" → click "Continue" → click "OK".

Stata:

svy linearized : ologit ENV_AFRDWLK_MCQ2 SEX_ASK_TRM i.Age_Grp i.Education i.WGHTS_PROV_TRM

Results comparison:

R SAS SPSS Stata
Population Est. Coeff. SE Coeff. SE Coeff. SE Coeff. SE

SEX_ASK_TRMM 0.1858 0.1640 0.1858 0.1640 0.1858 0.1642 0.1858 0.1642
Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.0222 0.2625 0.0222 0.2625 0.0222 0.2626 0.0222 0.2626
Age_Gpr3:Age 65-74 -0.3018 0.2715 -0.3017 0.2715 -0.3018 0.2716 -0.3018 0.2716

Age_Gpr4:Age 75+ -1.1128 0.3612 -1.1128 0.3612 -1.1128 0.3613 -1.1128 0.3613
Education Levels
(rel. to Lower Education)

Medium Education -0.0050 0.3708 -0.0053 0.3708 -0.0050 0.3706 -0.0050 0.3706
Higher Education lower -0.0676 0.3718 -0.0679 0.3571 -0.0676 0.3718 -0.0676 0.3718
Higher Education upper 0.4452 0.3702 0.4448 0.3539 0.4452 0.3702 0.4452 0.3702

Provinces
(rel. to Alberta)

British Columbia 0.0051 0.3534 0.0051 0.3551 0.0051 0.3535 0.0051 0.3535
Manitoba -0.0278 0.3475 -0.0279 0.3480 -0.0278 0.3476 -0.0278 0.3476

New Brunswick -0.2719 0.3735 -0.2720 0.3791 -0.2719 0.3739 -0.2719 0.3739
Newfoundland & Labrador 0.0873 0.3722 0.0873 0.3826 0.0873 0.3725 0.0873 0.3725

Nova Scotia -0.3400 0.4116 -0.3399 0.4013 -0.3400 0.4119 -0.3400 0.4119
Ontario -0.0991 0.3125 -0.0991 0.3232 -0.0991 0.3126 -0.0991 0.3126

Prince Edward Island -0.2458 0.3777 -0.2456 0.3815 -0.2458 0.3778 -0.2458 0.3778
Quebec 0.0286 0.3016 0.0286 0.3084 0.0286 0.3019 0.0286 0.3019

Saskatchewan -0.1627 0.3632 -0.1626 0.3724 -0.1627 0.3633 -0.1627 0.3633
(Intercepts)

Strongly Agree|Agree -4.0870 0.5553 -4.0873 0.5542 -4.0870 0.5553 -4.0870 0.5553
Agree|Disagree -2.0119 0.4760 -2.0122 0.4702 -2.0119 0.4760 -2.0119 0.4760

Disagree|Strongly Disagree 0.9929 0.4765 0.9926 0.4718 0.9929 0.4766 0.9929 0.4766

Note that the four response categories are for the question: "People would be afraid to walk alone
after dark in this area." The coefficient for the variable "SEX_ASK_TRM" is positive, which suggest that
male usually feel safer to walk alone after dark in the living area compared to female. The negative
coefficients of "Age_Gpr3:Age65-74" and "Age_Gpr4:Age75+" suggest that older people would feel un-
safe to walk alone in the dark. The results are in line with common sense.

Adjusted odds ratios, relative risks and risk ratios

Odds ratios, relative risks and risk ratios can be adjusted to specific factors. Suppose we fit a logistic
regression with the indicator variable of the target as the response and the exposure indicator and
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confounding variables as dependent variables,

logit(Pr(ITarget = 1|Iexposure)) = β0 + βIexposure + ∑
i

βiconfoundingi

Adjusted odds ratio =
Pr(ITarget = 1|Iexposure = 1)/ Pr(ITarget = 0|Iexposure = 1)

Pr(ITarget = 1|Iexposure = 0)/ Pr(ITarget = 0|Iexposure = 0)
= exp(β)

As suggested by Wacholder (1986), we fit a binomial regression with logarithmic, and identity link
functions for the adjusted relative risks, and risk difference, respectively. In the binomial regression
with logarithmic link function, we can obtain the adjusted relative risks as

log(Pr(ITarget = 1|Iexposure)) = β0 + βIexposure + ∑
i

βiconfoundingi

Adjusted relative risk =
Pr(ITarget = 1|Iexposure = 1)

Pr(ITarget = 1|Iexposure = 0)
= exp(β).

In the binomial regression with identity link function, we can obtain the adjusted risk differences as

Pr(ITarget = 1|Iexposure) = β0 + βIexposure + ∑
i

βiconfoundingi

Adjusted risk difference = Pr(ITarget = 1|Iexposure = 1)− Pr(ITarget = 1|Iexposure = 0) = β.

Suppose we want to study the relationship of experiencing dry mouth in the past 12 months (ORH_EXP_DRM_MCQ)
with sex (SEX_ASK_TRM) adjusted by the province variable (WGHTS_PROV_TRM) , age groups and the in-
dividual education, we can obtain the odds ratio, relative risk and risk ratio by the following codes:

R: As the number of dependent variable is large, we may need to specify the initial values in the
“start" option.

## Adjusted odds ratio

Adj.OR <- svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM +Age_Grp+ Education+WGHTS_PROV_TRM1 ,

family=quasibinomial(link="logit"),design=CLSA.design.anly)

exp(coef(Adj.OR)["SEX_ASK_TRM"]); exp(confint(Adj.OR)["SEX_ASK_TRM",])

## Adjusted risk ratio

Adj.RR <- svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM +Age_Grp+ Education+WGHTS_PROV_TRM1 ,

family=quasibinomial(link="log"),design=CLSA.design.anly,

start= c(-0.49, -0.45, 0.08, 0.42, 0.19, -0.59, -0.53,-0.61,

-0.90, -0.44,-0.33,-0.47,-0.11, -0.41, -0.63,-0.59,-0.66 ) )

exp(coef(Adj.RR)["SEX_ASK_TRM"]); exp(confint(Adj.RR)["SEX_ASK_TRM",])

## Adjusted risk difference

Adj.RD <- svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM +Age_Grp+ Education+WGHTS_PROV_TRM1 ,

family=quasibinomial(link="identity"),design=CLSA.design.anly,

start= c( 0.32,-0.09, 0.08, 0.15, 0.17,-0.06,-0.05,-0.06,

-0.16,-0.05,-0.01,-0.09, 0.07,-0.06,-0.09,-0.10, -0.15))

coef(Adj.RD)["SEX_ASK_TRM"] ; confint(Adj.RD)["SEX_ASK_TRM",]

SAS: There is no formal procedure for the adjusted relative risk and risk ratios. We would compare
the results from PROC GENMOD and the appropriate procedures from other statistic packages. The
correct approach can be archived with the SUDAAN package which we would not discuss here.
Interested readers may refer to Bieler et al. (2010).

/*Adjusted risk ratio without considering the survey design*/

PROC GENMOD data=CLSAData DESCENDING ;

CLASS ORH_EXP_DRM_MCQ SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /param=ref;

MODEL ORH_EXP_DRM_MCQ = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /dist=bin link=log ;

WEIGHT WGHTS_ANALYTIC_TRM;

ODS output ParameterEstimates=Est ;

RUN;

Data AdjRR;

SET Est(where= (Parameter ="SEX_ASK_TRM"));

AdjRR= exp(Estimate);

AdjRRLL = exp( LowerWaldCL) ;

AdjRRUL = exp( UpperWaldCL) ;
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RUN;

PROC PRINT data= AdjRR;format _numeric_ 10.8; run;

/*Adjusted risk difference without considering the survey design*/

PROC GENMOD data=CLSAData DESCENDING ;

CLASS ORH_EXP_DRM_MCQ SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM / param=ref;

MODEL ORH_EXP_DRM_MCQ = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM /dist=bin link=identity ;

WEIGHT WGHTS_ANALYTIC_TRM;

ODS output ParameterEstimates=AdjRD ;

RUN;

PROC PRINT data= AdjRD(where= (Parameter ="SEX_ASK_TRM"));

format _numeric_ 10.8; RUN;

SPSS: There is no formal procedure for obtaining adjusted odds ratios, relative risks and risk dif-
ferences in SPSS.

Stata:

svyset entity_id, strata(StraVar) weight(WGHTS_ANALYTIC_TRM) vce(linearized)

singleunit(certainty)

*adjusted odds ratio

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM i.Age_Grp i.Education i.WGHTS_PROV_TRM ,

fam(binomial) link(logit) eform

*adjusted relative risk

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM i.Age_Grp i.Education i.WGHTS_PROV_TRM ,

fam(binomial) link(log) difficult iterate(30000) eform

*adjusted risk difference

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM i.Age_Grp i.Education i.WGHTS_PROV_TRM ,

fam(binomial) link(identity) difficult iterate(30000)

Results comparison:

R SAS Stata
Adjusted odds ratio 0.5901 0.5901 0.5901

95% Lower confidence limit 0.3945 0.3927 0.3942
95% Upper confidence limit 0.8828 0.8867 0.8834

Adjusted relative risk 0.6848 0.6848 0.6848
95% Lower confidence limit 0.5039 0.5348 0.5024
95% Upper confidence limit 0.9306 0.8768 0.9333

Adjusted risk difference -0.0892 -0.0883 -0.0905
95% Lower confidence limit -0.1473 -0.1429 -0.1556
95% Upper confidence limit -0.0311 -0.0336 -0.0254

We can see the all the packages give the same adjusted odds ratio, relative risk and risk difference.
For the latter two cases, the R program and Stata give similar confidence limits as they consider the
survey designs in the variance estimation. In contrast, SAS gives significant narrower limits as it
ignores the survey design without the SUDAAN package. The adjusted risk differences shown vary
among the statistical packages as the convergence is not achieved. The differences are due to assorted
stopping criteria implemented in those program.

7. Domain Estimation

If we are interested in a particular group of units in the population, we may consider estimation
of subpopulation (domain) means. Domains are a concept at the estimation stage, which are often
different from strata which are subpopulations defined at the survey design stage. For instance, we
might be interested in people who have a university degree and those who do not have one. Treating
the subset of the original survey dataset with units belonging to the domain of interest as if it is a
stand-alone survey sample from the domain would yield incorrect standard errors. The following
codes describe the correct way to perform domain analyses.
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Estimation of domain proportions

If we are interested in understanding how people respond to the question, "People would be afraid
to walk alone after dark in this area" (ENV_AFRDWLK_MCQ) among the group of people with or without
a university degree, we may use the following codes.

R:

svymean(~ENV_AFRDWLK_MCQ1, design=subset(CLSA.design,ED_HIGH_TRM1=="Non_university") )

svymean(~ENV_AFRDWLK_MCQ1, design=subset(CLSA.design,ED_HIGH_TRM1=="University") )

SAS:

PROC SURVEYMEANS data= CLSAData mean;

VAR ENV_AFRDWLK_MCQ1;

DOMAIN ED_HIGH_TRM1;

STRATA GEOSTRAT_TRM;

WEIGHT WGHTS_INFLATION_TRM;

RUN;

SPSS:

Analyze → Complex Samples → Frequencies... → Select the file "CLSADesign.csaplan" in the Plan
panel → select ENV_AFRDWLK_MCQ to the Frequency Table panel → select ED_HIGH_TRM1 to the "Subpop-
ulations:" panel → click "Statistics..."→ select "Table percent" and "Standard error"→ click "Continue"→
click "OK".

Stata:

*We first change the survey design to that with inflation survey weight

svyset entity_id, strata(StraVar) weight(WGHTS_INFLATION_TRM) vce(linearized) singleunit(certainty)

* For people who never attained any university

svy linearized, subpop(if ED_HIGH_TRM1==0) : tabulate ENV_AFRDWLK_MCQ1 ,

cell se ci stubwidth(20) format(%10.0g)

* For people who have attained an university

svy linearized, subpop(ED_HIGH_TRM1) : tabulate ENV_AFRDWLK_MCQ1 ,

cell se ci stubwidth(20) format (%10.0g)

Results comparison:

R SAS SPSS Stata
ENV_AFRDWLK_MCQ Mean SE Mean SE Mean SE Mean SE

Group: Non university
Strongly Agree 0.0204 0.0077 0.0204 0.0077 0.0204 0.0077 0.0204 0.0077

Agree 0.1006 0.0161 0.1006 0.0161 0.1006 0.0161 0.1006 0.0161
Disagree 0.5751 0.0288 0.5751 0.0288 0.5751 0.0288 0.5751 0.0288

Strongly Disagree 0.2316 0.0254 0.2316 0.0254 0.2316 0.0254 0.2316 0.0254
Missing 0.0723 0.0165 0.0723 0.0165 0.0723 0.0165 0.0723 0.0165

Group: University
Strongly Agree 0.0112 0.0064 0.0112 0.0064 0.0112 0.0064 0.0112 0.0064

Agree 0.0751 0.0197 0.0751 0.0197 0.0751 0.0197 0.0751 0.0197
Disagree 0.5683 0.0351 0.5683 0.0351 0.5683 0.0351 0.5683 0.0351

Strongly Disagree 0.3112 0.0331 0.3112 0.0331 0.3112 0.0331 0.3112 0.0331
Missing 0.0342 0.0121 0.0342 0.0121 0.0342 0.0121 0.0342 0.0121

Estimation of domain quantiles

If we may want to estimate the population quantiles and medians of the self-reported body weight
and body height among people with or without a university degree, we may consider the following
codes.
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R:

# For people who did not attend an university

Quant.NUni<- svyquantile( ~ HWT_DHT_M_TRM+HWT_WGHT_KG_TRM , quantile=c(0.025,0.5,0.975),

alpha=0.05 ,interval.type="Wald", design= subset(CLSA.design,ED_HIGH_TRM1=="Non_university"),

ties=c("rounded"), ci= TRUE, se=TRUE )

Quant.NUni; SE(Quant.NUni);

# For people who attended an university

Quant.Uni<-svyquantile( ~ HWT_DHT_M_TRM+HWT_WGHT_KG_TRM , quantile=c(0.025,0.5,0.975),

alpha=0.05 , interval.type="Wald", design= subset(CLSA.design,ED_HIGH_TRM1=="University"),

ties=c("rounded"), ci= TRUE, se=TRUE )

Quant.Uni; SE(Quant.Uni);

In SAS, SPSS and Stata packages, there is no formal procedure available to produce quantile estimates
for domain analysis.

R program Output:

HWT_DHT_M_TRM HWT_WGHT_KG_TRM

Quantiles Non_university University Non_university University
Estimate 0.025 1.5109 1.5137 48.9258 51.3353

0.05 1.5311 1.5311 51.7980 53.9833
0.1 1.5537 1.5571 55.4990 57.4062
0.5 1.6579 1.6711 76.7963 73.4840
0.9 1.7714 1.8003 101.5681 94.5099

0.95 1.8024 1.8276 109.9035 99.9627
0.975 1.8277 1.8682 122.8340 108.1732

SE 0.025 0.0073 0.0013 1.0451 1.9207
0.05 0.0051 0.0102 0.8544 0.6790

0.1 0.0052 0.0064 0.9990 0.9227
0.5 0.0072 0.0090 1.2966 1.2862
0.9 0.0108 0.0120 3.1358 2.3605

0.95 0.0141 0.0224 3.9499 3.5970
0.975 0.0300 0.0315 7.2118 5.2620

Linear regression in domain analysis

If we want to investigate the relationship of self-reported height and weight within the subpopulation
which are interviewed in English, we may apply the following codes.

R:

LinearReg_EN<-svyglm( HWT_DHT_M_TRM~ HWT_WGHT_KG_TRM+ SEX_ASK_TRM + Age_Grp+Education +

WGHTS_PROV_TRM1, family="gaussian", design=subset(CLSA.design.anly, startlanguage="en" ) )

summary(LinearReg_EN)

SAS:

PROC SURVEYREG data=CLSAData ;

CLASS SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1;

MODEL HWT_DHT_M_TRM = HWT_WGHT_KG_TRM SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 / solution ;

WEIGHT WGHTS_ANALYTIC_TRM;

STRATA GEOSTRAT_TRM ;

DOMAIN startlanguage;

ods output ParameterEstimates=Est;

RUN;

PROC PRINT data= EST;

where startlanguage =="en";

format _numeric_ 15.9; run;
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SPSS:

Analyze → Complex Samples → General Linear Model... → Select the file "CLSADesignAnyl.csaplan"
in the Plan panel → select [Target Variables] to the "Dependent Variable", "Factor" and "Covariate"
panels → select “startlanguage" to the “Subpopulations" panel and enter the target category → click
"Statistics..." → select "Estimate" and "Standard error" → click "Continue" → click "OK"

Stata:

svyset entity_id, strata(StraVar) weight(WGHTS_ANALYTIC_TRM) vce(linearized)

singleunit(certainty)

svy linearized, subpop(if startlanguage = "en"):

regress HWT_DHT_M_TRM HWT_WGHT_KG_TRM SEX_ASK_TRM i.Age_Grp i.Education i.WGHTS_PROV_TRM

estimates table, b(%10.0g) se(%10.0g)

Results comparison:

R SAS SPSS Stata
Population Est. Coeff. SE Coeff. SE Coeff. SE Coeff. SE

(Intercept) 1.620E+0 1.832E-2 1.620E+0 1.850E-2 1.620E+0 1.832E-2 1.620E+0 1.832E-2
HWT_WGHT_KG_TRM -6.692E-6 2.552E-6 -6.692E-6 2.578E-6 -6.692E-6 2.552E-6 -6.692E-6 2.552E-6

SEX_ASK_TRMM 1.284E-1 6.105E-3 1.284E-1 6.166E-3 1.284E-1 6.105E-3 1.284E-1 6.105E-3
Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 1.586E-2 9.971E-3 1.586E-2 1.007E-2 1.586E-2 9.971E-3 1.586E-2 9.971E-3
Age_Gpr3:Age 65-74 8.436E-3 1.039E-2 8.436E-3 1.049E-2 8.436E-3 1.039E-2 8.436E-3 1.039E-2

Age_Gpr4:Age 75+ -8.594E-3 1.311E-2 -8.594E-3 1.324E-2 -8.594E-3 1.311E-2 -8.594E-3 1.311E-2
Education Levels
(rel. to Lower Education)

Medium Education -8.157E-3 1.402E-2 -8.157E-3 1.416E-2 -8.157E-3 1.402E-2 -8.157E-3 1.402E-2
Higher Education lower -4.174E-3 1.393E-2 -4.174E-3 1.407E-2 -4.174E-3 1.393E-2 -4.174E-3 1.393E-2
Higher Education upper 1.050E-2 1.381E-2 1.050E-2 1.395E-2 1.050E-2 1.381E-2 1.050E-2 1.381E-2

Provinces
(rel. to Alberta)

British Columbia 1.386E-2 1.081E-2 1.386E-2 1.092E-2 1.386E-2 1.081E-2 1.386E-2 1.081E-2
Manitoba 7.181E-3 1.179E-2 7.181E-3 1.191E-2 7.181E-3 1.179E-2 7.181E-3 1.179E-2

New Brunswick 4.231E-3 1.299E-2 4.231E-3 1.312E-2 4.231E-3 1.299E-2 4.231E-3 1.299E-2
Newfoundland & Labrador -7.063E-4 1.161E-2 -7.063E-4 1.172E-2 -7.063E-4 1.161E-2 -7.063E-4 1.161E-2

Nova Scotia 5.168E-3 1.215E-2 5.168E-3 1.227E-2 5.168E-3 1.215E-2 5.168E-3 1.215E-2
Ontario -5.462E-5 1.111E-2 -5.462E-5 1.122E-2 -5.462E-5 1.111E-2 -5.462E-5 1.111E-2

Prince Edward Island -7.639E-3 1.234E-2 -7.639E-3 1.247E-2 -7.639E-3 1.234E-2 -7.639E-3 1.234E-2
Quebec -2.335E-3 1.071E-2 -2.335E-3 1.082E-2 -2.335E-3 1.071E-2 -2.335E-3 1.071E-2

Saskatchewan -1.479E-2 1.294E-2 -1.479E-2 1.307E-2 -1.479E-2 1.294E-2 -1.479E-2 1.294E-2

Logistic regression in domain analysis

If we want to investigate the experiencing dry mouth indicated by the variable “ORH_EXP_DRM_MCQ"
for the group of people who responses in English, we may apply the following codes.

R:

LogisticReg3_EN<-svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM + Age_Grp+Education +

WGHTS_PROV_TRM1, family=quasibinomial,

design=subset(CLSA.design.anly, startlanguage=="en" ))

summary(LogisticReg3_EN)

SAS:

PROC SURVEYLOGISTIC data=CLSAData ;

class ORH_EXP_DRM_MCQ(ref=first) SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /param=ref ;

model ORH_EXP_DRM_MCQ = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /clodds ;

strata GEOSTRAT_TRM ;

weight WGHTS_ANALYTIC_TRM;



25

DOMAIN startlanguage;

ods output ParameterEstimates=Est;

RUN;

PROC PRINT data= EST;

where startlanguage ="en";

format _numeric_ 15.9; run;

SPSS:

Analyze → Complex Samples → Logistic Regression... -→ Select the file "CLSADesignAnyl.csaplan"
in the Plan panel →select [Target Variables] to the "Dependent Variable", "Factor" and "Covariate"
panels → Select startlanguage to "Subpopulation" and enter the target category → Click "Reference
Category" and select "Lowest value" → Click "Statistics..." → select "Estimate" and "Standard error"
→ Click "Continue" → Click "OK".

Stata:

svyset entity_id, strata(StraVar) weight(WGHTS_ANALYTIC_TRM) vce(linearized) singleunit(certainty)

svy linearized, subpop(if startlanguage=="en"): logit ORH_EXP_DRM_MCQ SEX_ASK_TRM

i.Age_Grp i.Education i.WGHTS_PROV_TRM

Results comparison:

R SAS SPSS Stata
Population Est. Coeff. SE Coeff. SE Coeff. SE Coeff. SE

(Intercept) -1.1999 0.6269 -1.1999 0.6267 -1.1999 0.6268 -1.1999 0.6268
SEX_ASK_TRMM -0.4935 0.2430 -0.4935 0.2452 -0.4935 0.2429 -0.4935 0.2429

Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.5201 0.3854 0.5201 0.3890 0.5201 0.3854 0.5201 0.3854
Age_Gpr3:Age 65-74 0.6968 0.3931 0.6968 0.3968 0.6968 0.3931 0.6968 0.3931

Age_Gpr4:Age 75+ 0.5663 0.5104 0.5663 0.5151 0.5663 0.5104 0.5663 0.5104
Education Levels
(rel. to Lower Education)

Medium Education 0.0282 0.4504 0.0282 0.4547 0.0282 0.4504 0.0282 0.4504
Higher Education lower 0.0865 0.4430 0.0865 0.4472 0.0865 0.4430 0.0865 0.4430
Higher Education upper 0.0382 0.4411 0.0382 0.4452 0.0382 0.4411 0.0382 0.4411

Provinces
(rel. to Alberta)

British Columbia -0.9167 0.4557 -0.9167 0.4600 -0.9167 0.4557 -0.9167 0.4557
Manitoba -0.2713 0.4404 -0.2713 0.4446 -0.2713 0.4404 -0.2713 0.4404

New Brunswick 0.0530 0.4624 0.0530 0.4668 0.0530 0.4624 0.0530 0.4624
Newfoundland & Labrador -0.4328 0.4701 -0.4328 0.4745 -0.4328 0.4701 -0.4328 0.4701

Nova Scotia 0.3214 0.4465 0.3214 0.4507 0.3214 0.4465 0.3214 0.4465
Ontario -0.2059 0.4234 -0.2059 0.4274 -0.2059 0.4234 -0.2059 0.4234

Prince Edward Island -0.3867 0.4742 -0.3867 0.4787 -0.3867 0.4742 -0.3867 0.4742
Quebec 0.0334 1.2551 0.0334 1.2669 0.0334 1.2551 0.0334 1.2551

Saskatchewan -0.6197 0.4842 -0.6197 0.4888 -0.6197 0.4842 -0.6197 0.4842

Multinomial logistic regression in domain analysis

Suppose we are interested in the current marital statuses (single, married and others) of the subpop-
ulation which uses English to answer the questionnaire.

R: There is no official support for multinomial regression from the R survey package.

SAS:

PROC SURVEYLOGISTIC data=CLSAExample ;

class WEA_MRTL_CURRENT_MCQ2 SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /param=ref ;

model WEA_MRTL_CURRENT_MCQ2 = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM

/clodds link=glogit ;
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strata GEOSTRAT_TRM ;

weight WGHTS_ANALYTIC_TRM;

DOMAIN startlanguage;

ods output ParameterEstimates=Est;

RUN;

Proc sort data= EST Out= MyParmEst ;

by Response;

where startlanguage = "en";

run;

Proc print data= MyParmEst; run;

SPSS:

Analyze → Complex Samples → Logistc Regression... → Select the file "CLSADesignAnyl.csaplan" in
the Plan panel → click "Continue" → select the corresponding variables to the "Dependent Variable",
"Factor" and "Covariate" panels → click "Reference Category" and select "Lowest value" → select
“startlanguage" to the “Subpopulations" panel and enter the target category → click "Statistics..." →
select "Estimate" and "Standard error" → click "Continue" → click "OK".

Stata:

.svy linearized, subpop(if startlanguage=="en"): mlogit MRTL_CURRENT1 SEX_ASK_TRM

i.Age_Grp i.Education i.WGHTS_PROV_TRM , baseoutcome(1)

Results comparison
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Response: Marital status SAS SPSS Stata
(reltaive to 1:Single) Coeff. SE Coeff. SE Coeff. SE

2:Married (Intercept) 1.4474 0.8645 1.4474 0.8472 1.4474 0.8473
SEX_ASK_TRMM 0.3229 0.3330 0.3229 0.3264 0.3229 0.3264

Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.1035 0.4614 0.1035 0.4522 0.1035 0.4522
Age_Gpr3:Age 65-74 0.2171 0.5082 0.2171 0.4981 0.2171 0.4981

Age_Gpr4:Age 75+ 0.0641 0.7510 0.0641 0.7361 0.0642 0.7360
Education Levels
(rel. to Lower Education)

Medium Education 0.7869 0.6700 0.7869 0.6566 0.7868 0.6566
Higher Education lower 0.6634 0.6757 0.6634 0.6622 0.6632 0.6622
Higher Education upper 0.6766 0.6598 0.6766 0.6466 0.6765 0.6466

Provinces
(rel. to Alberta)

British Columbia 0.1227 0.6426 -0.1227 0.6298 -0.1227 0.6298
Manitoba -0.5767 0.5746 -0.5767 0.5632 -0.5767 0.5632

New Brunswick 1.1966 0.9283 1.1966 0.9098 1.1964 0.9096
Newfoundland & Labrador 0.0134 0.7622 0.0134 0.7470 0.0134 0.7470

Nova Scotia 0.3181 0.7298 0.3181 0.7152 0.3181 0.7152
Ontario -0.4585 0.5925 -0.4586 0.5807 -0.4585 0.5807

Prince Edward Island -1.2155 0.6200 -1.2156 0.6076 -1.2155 0.6076
Quebec 10.8952 1.0901 19.8953 44.4727 11.0231 1.0684

Saskatchewan 1.6480 1.1639 1.6480 1.1407 1.6479 1.1405

3:Others (Intercept) -0.3943 1.0915 -0.3943 1.0697 -0.3941 1.0700
SEX_ASK_TRMM -0.9348 0.4082 -0.9348 0.4000 -0.9348 0.4000

Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 0.7266 0.6366 0.7266 0.6239 0.7266 0.6239
Age_Gpr3:Age 65-74 1.2753 0.6375 1.2753 0.6542 1.2753 0.6542

Age_Gpr4:Age 75+ 2.4720 0.8747 2.4720 0.8573 2.4717 0.8573
Education Levels
(rel. to Lower Education)

Medium Education 1.3776 0.7555 1.3776 0.7405 1.3774 0.7405
Higher Education lower 1.0669 0.7652 1.0669 0.7500 1.0668 0.7500
Higher Education upper 0.7486 0.7482 0.7486 0.7333 0.7485 0.7333

Provinces
(rel. to Alberta)

British Columbia -0.5309 0.7182 -0.5309 0.7039 -0.5309 0.7039
Manitoba -0.4322 0.6666 -0.4322 0.6533 -0.4322 0.6533

New Brunswick 0.8279 0.9989 0.8279 0.9790 0.8276 0.9788
Newfoundland & Labrador -0.9295 0.8564 -0.9295 0.8394 -0.9295 0.8394

Nova Scotia 0.1844 0.8124 0.1844 0.7961 0.1845 0.7961
Ontario -0.9148 0.6883 -0.9148 0.6745 -0.9148 0.6746

Prince Edward Island -1.3522 0.7260 -1.3522 0.7116 -1.3522 0.7116
Quebec 11.7396 1.1539 20.7397 44.4759 11.8674 1.1309

Saskatchewan 1.1034 1.2184 1.1034 1.1941 1.1032 1.1940

Ordinal logistic regression in domain analysis

Suppose we are interested in the variable ENV_AFRDWLK_MCQ2 for the group of people who answer the
questionnaire .

R:

summary( svyolr(formula = ENV_AFRDWLK_MCQ2 ~ SEX_ASK_TRM + Age_Grp+Education +

WGHTS_PROV_TRM1, design = subset(CLSA.design.anly, startlanguage == "en"),

na.action = na.omit, method = c("logistic")) )

SAS:

PROC SURVEYLOGISTIC data=CLSAData ;

class ENV_AFRDWLK_MCQ2 SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /param=ref ;

model ENV_AFRDWLK_MCQ2 = SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1 /clodds ;

strata GEOSTRAT_TRM ;

weight WGHTS_ANALYTIC_TRM;

DOMAIN startlanguage;
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ods output ParameterEstimates=Est;

RUN;

Proc print data= EST;

where startlanguage = "en";

run;

SPSS:

Analyze → Complex Samples → Ordinal Regression... → Select the file "CLSADesignAnyl.csaplan"
in the Plan panel → click "Continue" → select the corresponding variables to the "Dependent Vari-
able", "Factor" and "Covariate" panels → click "Response Probabilities" and select "Accumulate from
lowest value of dependent variable to highest value" → select “startlanguage" to the “Subpopula-
tions" panel and enter the target category → click "Statistics..." → select "Estimate" and "Standard
error" → click "Continue" → click "OK".

Stata:

svy linearized, subpop(if startlanguage=="en"): ologit ENV_AFRDWLK_MCQ2 SEX_ASK_TRM

i.Age_Grp i.Education i.WGHTS_PROV_TRM

Results comparison:

R SAS SPSS Stata
Population Est. Coeff. SE Coeff. SE Coeff. SE Coeff. SE

SEX_ASK_TRMM 0.1143 0.1856 0.1144 0.1843 0.1143 0.1856 0.1143 0.1857
Age Groups

(rel. to Age_Gpr1: Age 45-54)
Age_Gpr2:Age 55-64 -0.1966 0.2905 -0.1966 0.2943 -0.1966 0.2906 -0.1966 0.2906
Age_Gpr3:Age 65-74 -0.2809 0.3042 -0.2809 0.3089 -0.2809 0.3042 -0.2809 0.3042

Age_Gpr4:Age 75+ -1.3462 0.4110 -1.3463 0.4181 -1.3462 0.4110 -1.3462 0.4111
Education Levels
(rel. to Lower Education)

Medium Education -0.4414 0.5166 -0.4418 0.4706 -0.4414 0.5164 -0.4414 0.5164
Higher Education lower -0.4246 0.5075 -0.4251 0.4646 -0.4246 0.5075 -0.4246 0.5075
Higher Education upper 0.2872 0.4957 0.2868 0.4516 0.2872 0.4955 0.2872 0.4955

Provinces
(rel. to Alberta)

British Columbia 0.0473 0.3470 0.0473 0.3493 0.0473 0.3472 0.0473 0.3472
Manitoba -0.0188 0.3430 -0.0188 0.3445 -0.0188 0.3431 -0.0188 0.3431

New Brunswick -0.3852 0.3853 -0.3852 0.3915 -0.3852 0.3856 -0.3852 0.3856
Newfoundland & Labrador 0.0984 0.3654 0.0983 0.3769 0.0984 0.3657 0.0984 0.3657

Nova Scotia -0.2964 0.4086 -0.2964 0.3966 -0.2964 0.4090 -0.2964 0.4090
Ontario 0.0354 0.3114 0.0354 0.3229 0.0354 0.3115 0.0354 0.3115

Prince Edward Island -0.2438 0.3729 -0.2436 0.3735 -0.2438 0.3730 -0.2438 0.3730
Quebec 1.6611 1.3156 1.6609 1.3633 1.6611 1.3156 1.6611 1.3156

Saskatchewan -0.1442 0.3590 -0.1441 0.3681 -0.1442 0.3591 -0.1442 0.3591
(Intercepts)

Strongly Agree|Agree -4.6354 0.6558 -4.6359 0.6316 -4.6354 0.6556 -4.6354 0.6557
Agree|Disagree -2.3937 0.5952 -2.3942 0.5627 -2.3937 0.5950 -2.3937 0.5951

Disagree|Strongly Disagree 0.5987 0.5916 0.5987 0.5597 0.5987 0.5916 0.5987 0.5916

Adjusted odds ratio, relative risks and risk ratios in domain analysis

Suppose we want to study the relationship of experiencing dry mouth in the past 12 months (ORH_EXP_DRM_MCQ)
with sex (SEX_ASK_TRM) adjusted by the province variable (WGHTS_PROV_TRM) , age groups and the in-
dividual education for the people who complete the questionnaire with English, we can obtain the
odds ratio, relative risk and risk ratio by the following codes:

R: As the number of dependent variable is large, we may need to specify the initial values in the
“start" option.

## Adjusted odds ratio

Adj.OR <- svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM +Age_Grp+ Education+WGHTS_PROV_TRM1 ,
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family=quasibinomial(link="logit"),design=subset(CLSA.design.anly,

startlanguage == "en"))

exp(coef(Adj.OR)["SEX_ASK_TRM"]); exp(confint(Adj.OR)["SEX_ASK_TRM",])

## Adjusted risk ratio

Adj.RR <- svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM +Age_Grp+ Education+WGHTS_PROV_TRM1 ,

family=quasibinomial(link="log"),design=subset(CLSA.design.anly,

startlanguage == "en"), start= c(-0.49, -0.45, 0.08, 0.42, 0.19,

-0.59, -0.53,-0.61,-0.90, -0.44,-0.33,-0.47,-0.11, -0.41, -0.63,-0.59,-0.66))

exp(coef(Adj.RR)["SEX_ASK_TRM"]); exp(confint(Adj.RR)["SEX_ASK_TRM",])

## Adjusted risk difference

Adj.RD <- svyglm( ORH_EXP_DRM_MCQ ~ SEX_ASK_TRM +Age_Grp+ Education+WGHTS_PROV_TRM1 ,

family=quasibinomial(link="identity"),design=subset(CLSA.design.anly,

startlanguage == "en"), start= c( 0.32,-0.09, 0.08, 0.15, 0.17,

-0.06,-0.05,-0.06, -0.16,-0.05,-0.01,-0.09, 0.07,-0.06,-0.09,-0.10, -0.15))

coef(Adj.RD)["SEX_ASK_TRM"] ; confint(Adj.RD)["SEX_ASK_TRM",]

SAS: There is no formal procedure for the adjusted relative risk and risk ratios. We would compare
the results from PROC GENMOD and the appropriate procedures from other statistic packages. The
correct approach can be archived with the SUDAAN package which we would not discuss here.
Interested readers may refer to Bieler et al. (2010).

PROC SURVEYLOGISTIC data=CLSAData ;

CLASS ORH_EXP_DRM_MCQ SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1/param=ref;

MODEL ORH_EXP_DRM_MCQ (event='1')= SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM

/clodds;

STRATA GEOSTRAT_TRM;

WEIGHT WGHTS_ANALYTIC_TRM;

DOMAIN startlanguage;

ODS output CLOddsWald=CLOddsWald ;

RUN;

PROC PRINT data=CLOddsWald;

format _numeric_ 10.8;

where startlanguage eq "en";

title "Odds Ratio Estimates";

RUN;

/*Adjusted risk ratio without considering the survey design*/

PROC GENMOD data=CLSAData DESCENDING ;

CLASS ORH_EXP_DRM_MCQ SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1/param=ref;

MODEL ORH_EXP_DRM_MCQ (event='1')= SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM

/dist=bin link=log;

WEIGHT WGHTS_ANALYTIC_TRM;

where startlanguage eq "en";

ODS output ParameterEstimates=Est ;

RUN;

Data AdjRR;

SET Est(where= (Parameter ="SEX_ASK_TRM"));

AdjRR= exp(Estimate);

AdjRRLL = exp( LowerWALDCL) ;

AdjRRUL = exp( UpperWALDCL) ;

RUN;

PROC PRINT data= AdjRR;format _numeric_ 10.8; run;

/*Adjusted risk difference without considering the survey design*/

PROC GENMOD data=CLSAData DESCENDING ;

CLASS ORH_EXP_DRM_MCQ SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM1/param=ref;

MODEL ORH_EXP_DRM_MCQ (event='1')= SEX_ASK_TRM Age_Grp Education WGHTS_PROV_TRM

/dist=bin link=identity;

where startlanguage eq "en";

ODS output ParameterEstimates=AdjRD ;

RUN;

PROC PRINT data= AdjRD(where= (Parameter ="SEX_ASK_TRM"));

format _numeric_ 10.8; RUN;
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SPSS: There is no formal procedure for obtaining adjusted odds ratios, relative risks and risk dif-
ferences in SPSS.

Stata:

svyset entity_id, strata(StraVar) weight(WGHTS_ANALYTIC_TRM) vce(linearized)

singleunit(certainty)

*adjusted odds ratio

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM i.Age_Grp i.Education

i.WGHTS_PROV_TRM , fam(binomial) link(logit) eform

*adjusted relative risk

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM i.Age_Grp i.Education

i.WGHTS_PROV_TRM , fam(binomial) link(log) difficult iterate(30000) eform

*adjusted risk difference

svy linearized: glm ORH_EXP_DRM_MCQ SEX_ASK_TRM i.Age_Grp i.Education

i.WGHTS_PROV_TRM , fam(binomial) link(identity) difficult iterate(30000)

Results comparison:

R SAS Stata

Adjusted odds ratio 0.6105 0.6105 0.6105
95% Lower confidence limit 0.3792 0.3725 0.3790
95% Upper confidence limit 0.9829 0.9879 0.9835

Adjusted relative risk 0.7028 0.7028 0.7028
95% Lower confidence limit 0.4908 0.5313 0.4866
95% Upper confidence limit 1.0063 0.9296 1.0150

Adjusted risk difference -0.0827 -0.0794 -0.0844
95% Lower confidence limit -0.1523 -0.1471 -0.1635
95% Upper confidence limit -0.0132 -0.0117 -0.0553

Again, we can see the all the packages give the same adjusted odds ratio, relative risk and risk differ-
ence. For the latter two cases, the R program and Stata give similar confidence limits as they consider
the survey designs in the variance estimation. In contrast, SAS gives noticeably narrower limits as it
ignores the survey design without the SUDAAN package. The adjusted risk differences shown vary
among the statistical packages as the convergence is not achieved. The differences are due to assorted
stopping criteria implemented in those program.

This domain analysis is for the researchers who are just interested in the adjusted odds ratios,
relative risks and risk differences of the sub population. If the comparison of the odds ratio between
different sub populations is preferred, then we suggest adding the sub-population indicators as part
of the covariates in the regression equations to obtain the adjusted odds ratios.

What if we ignore domain analysis

If we do not specify the subpopulation in a survey and treat the subset of the dataset as a separate
survey, the resulting standard error would be incorrect. We would compare the difference in SE by
the R program. Here, we give an extreme example to emphasize the effect if we do not specify the
subpopulation. Suppose we are interested in the ENV_AFRDWLK_MCQ variable and want to compare it
between people with BMI below and above 19. There are 22 and 842 respondents with BMI < 19 and
those have at least 19, respectively. Here are the codes for such a comparison.

# It is correct to specify the subpopulations

svytotal(~ENV_AFRDWLK_MCQ1, design=subset(CLSA.design,BMI<19) )

svytotal(~ENV_AFRDWLK_MCQ1, design=subset(CLSA.design,BMI>=19))

# It is not appropriate if we divide the dataset and re-declare the survey design

CLSAData.low.BMI <-CLSAData[which(CLSAData$BMI<19), ]

CLSAData.high.BMI<-CLSAData[which(CLSAData$BMI>=19),]

CLSA.design.low.BMI<- svydesign( ids= ~ entity_id, strata = ~ StraVar,

weights = ~ WGHTS_INFLATION_TRM, data= CLSAData.low.BMI, nest =TRUE )

CLSA.design.high.BMI<- svydesign( ids= ~ entity_id, strata = ~ StraVar,
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weights = ~ WGHTS_INFLATION_TRM, data= CLSAData.high.BMI, nest =TRUE )

svytotal(~ENV_AFRDWLK_MCQ1, design=CLSA.design.low.BMI)

svytotal(~ENV_AFRDWLK_MCQ1, design=CLSA.design.high.BMI)

Results comparison:

Subpopulation Specified Not Specified
Total SE Total SE

Group:BMI < 19
Strongly Agree 644.35 644.35 644.35 0

Agree 3296.81 1957.95 3296.81 1521.17
Disagree 5474.52 1545.81 5474.52 1041.11

Strongly Disagree 1022.27 1022.27 1022.27 1022.27
Missing 252.07 252.07 252.07 252.07

Group:BMI ≥ 19
Strongly Agree 7969.5 2635.7 7969.5 2635.4

Agree 43421.6 6251.3 43421.6 6245.4
Disagree 291481.6 12714.4 291481.6 12612.9

Strongly Disagree 136278 10992.8 136278 10955.7
Missing 29058.6 5682.1 29058.6 5680.7

Readers can see that the estimates for the total are the same for both groups, while there are substan-
tial differences in the standard error. If we specify the subpopulation, the standard errors given by the
program would be more reasonable and generally slightly higher. It is because the statistical package
would treat the sizes of subpopulations to be random in domain analysis, and therefore, there is more
uncertainty in the population estimates.

Note: The total of the sub population estimates from the table above is much smaller that the CLSA
study population. It is because the dataset used for illustration is only a subset of the CLSA dataset.
The actual dataset should give much larger sub population totals.

8. Concluding remarks

This paper has outlined the appropriate steps to import, prepare and analyze datasets from CLSA
using R, SAS, SPSS and Stata. From the comparisons presented in the paper, we see that R provides
accurate and reliable estimates and standard errors as an attractive statistical package. The data ma-
nipulation and analysis codes in R described in the paper can be generalized to other datasets from
surveys with a sampling scheme similar to the CLSA.

This paper highlights the comparison of the codes between R and other commercial statistical
packages for different statistical procedures. The survey packages in R provides most of the proce-
dures in which health policy researchers are interested. Comparing with other packages, R is easy to
use, flexible and open-source. We recommend that health researchers choose R as one of the statisti-
cal packages for data analyses.

This paper can also serve as a cookbook for the health policy analysts who can check the corre-
sponding codes for various statistical analyses for different statistical packages. This paper would be
part of the groundwork for health-care survey administration organizations to include instructions
and sample R codes in their technical documentation.

Version notes

The calculations in this paper were performed with R version 3.6.3, using the R survey package
version 3.37. Statistical package comparisons were calculated using SAS version 9.4 with SAS/STAT
version 15.1, SPSS Version 25 and Stata/SE version 15.0.
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