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Abstract

Complex design tasks often require perform-
ing diverse actions in a specific order. To
(semi-)autonomously accomplish these tasks,
applications need to understand and learn a
wide range of design procedures, i.e., Creative
Procedural-Knowledge (CPK). Prior knowl-
edge base construction and mining have not
typically addressed the creative fields, such as
design and arts. In this paper, we formalize an
ontology of CPK using five components: goal,
workflow, action, command and usage; and
extract components’ values from online design
tutorials. We scraped 19.6K tutorial-related
webpages and built a web application for pro-
fessional designers to identify and summarize
CPK components. The annotated dataset con-
sists of 819 unique commands, 47,491 actions,
and 2,022 workflows and goals. Based on
this dataset, we propose a general CPK extrac-
tion pipeline and demonstrate that existing text
classification and sequence-to-sequence mod-
els are limited in identifying, predicting and
summarizing complex operations described in
heterogeneous styles. Through quantitative
and qualitative error analysis, we discuss CPK
extraction challenges that need to be addressed
by future research.

1 Introduction

Building applications that can enhance human
abilities to accomplish creative tasks (such as
writing summaries, designing graphics, and com-
posing music) has recently captured a significant
amount of attention from academia and indus-
try (Ganin et al., 2018; Simon and Oore, 2017;
See et al., 2017). In the domain of design and
imaging, these tasks often require micro-controls
over pixels, shapes, and objects and involve mul-
tiple steps of operations. For example, drawing
a creative cartoon typically requires several iter-
ations of an action sequence (contouring, brush-

ing, coloring) applied to different areas on the can-
vas. Therefore, to realize a wide range of intel-
ligent tasks (such as next-tool recommendation,
auto-completion, personalized interface, and de-
sign material retrieval), applications need to gain
Creative Procedural-Knowledge (CPK).

In this paper we exploit the opportunity for ma-
chine learning algorithms to extract CPK from
the growing corpus of online tutorials. Creative
professionals document detailed actions and steps
for using design software (e.g., Photoshop, GIMP,
Inkspace, and Autodesk) in online design tutorials.
These tutorials can be in the form of text, image, or
video and may vary in quality, length, and topics.
For example, envatotuts+ website1 contains tuto-
rials for text effects, sketches, watercolor painting,
and animation. To the best of our knowledge, few
prior work investigated the problem of parsing and
extracting knowledge from free-text tutorials. Ex-
isting research on mining web content has been
mostly focused on articles (Ren et al., 2017) and
scientific papers (Zhang, 2015), and the tasks are
limited to tagging (Joulin et al., 2017), name en-
tity recognition (Manning et al., 2014), and sum-
marization (See et al., 2017). Prior work on pars-
ing cooking recipes (Jermsurawong and Habash,
2015; Chen, 2017) investigated clean and struc-
tured documents where ingredients are presented
upfront, and instructions are described step-by-
step without irrelevant or redundant information.
In comparison, tutorials are much more diverse
and unstructured, and the CPK extends beyond
name entities, topics, and a fixed list of ingredi-
ents.

To facilitate and benchmark research, we pro-
pose an ontology for CPK using the workflow rep-
resentation that consists of goal, workflow, action,
command and usage (Section 3). Based on the de-

1https://design.tutsplus.com
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https://design.tutsplus.com/tutorials/create-an-easy-glitter-glue-inspired-text-effect-in-adobe-photoshop--cms-21249
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Figure 1: Sample CPK (Section 3) annotations for
a design tutorial. A professional designer is in-
structed to identity relevant text chunks and sum-
marize for the goal and actions. For each action, a
command is also labeled.

fined ontology, we collect thousands of text-based
Adobe Photoshop tutorials from hundreds of do-
mains and build a web application to elicit labels
from professional designers. Our application al-
lows annotators to flexibly extract and summa-
rize various components and specify the sources
from which the knowledge is derived. Finally, our
dataset contains 819 unique commands, 47,491
actions, and 2,022 workflows and goals. A rep-
resentative set of annotations is shown in Fig. 1.
The code and dataset are available at https:
//github.com/ylongqi/cpk. With the
dataset, we quantitatively and qualitatively present
the challenges of CPK extraction. Specifically,
we demonstrate that existing text classification and
sequence-to-sequence models (Sutskever et al.,
2014) fall short in handling heterogeneous writing
styles of different tutorials. As a result, predictive
models are suboptimal in identifying and classify-
ing implicit- or latent-mentioned commands and
produce low quality summaries for complex oper-
ations.

Since CPK stores valuable procedural knowl-
edge necessary for diverse design tasks, it can po-
tentially enable or enhance a wide range applica-
tions. For example, (a) smarter tutorial search
and recommendation. CPK can enable com-
mand, action and intention-based search that are
beyond text matching. Similarly, tutorial recom-

mendations can be conducted based on the goal
that an user plans to achieve or the commands and
operations that she aspires to learn; (b) skill trees
and personalized curriculum. A large collec-
tion of CPK provides resources to contruct skill
trees that encode the rank of each operation, which
can power personalized curriculum, and (c) au-
tonomous design agents. CPK provides map-
pings from design goals to action and command
sequences. An autonomous design agent can be
trained supervisedly to act on users’ queries; In
addition, since each annotated CPK directly cor-
responds to a tutorial, the collected dataset can be
used for tutorial generations based on given com-
mand sequences and goal descriptions.

2 Related Work

Our work is related to and inspired by previous
research on knowledge base construction and doc-
ument modeling. The extracted CPK has applica-
tions to computational creativity.

2.1 Knowledge base construction

A knowledge base (graph) (Bollacker et al., 2008;
Liu et al., 2010) stores facts using triplets (ei,
ej , r), where ei and ej are generic entities (e.g.,
person, location, and event), or domain-specific
entities (e.g. drug and effect), and r is a rela-
tion that builds connections between ei and ej
(e.g., a drug has a effect, and a person lives in
a location). The process of Knowledge Base
Construction (KBC) (Niu et al., 2012; Mitchell
et al., 2018; Mahdisoltani et al., 2013; Ritter,
2013; Zhang, 2015) is to extract triplets from free
text (Mitchell et al., 2018; Liu et al., 2017) or
structured tables (Ran et al., 2015; Crestan and
Pantel, 2010). Prior work has proposed diverse
approaches for the extraction, such as supervised
methods (Bunescu and Mooney, 2005), semi- or
weakly supervised algorithms (Liu et al., 2010;
Mahdisoltani et al., 2013; Mitchell et al., 2018;
Jiang et al., 2012), and distantly-supervised algo-
rithms (Liu et al., 2017; Zhang, 2015; Surdeanu
et al., 2012; Angeli et al., 2014; Ren et al., 2017).
These approaches require different levels human
labeling efforts and are shown to vary in precision
and recall. However, while existing knowledge
bases have enabled important applications (such
as web search (Deshpande et al., 2013) and ques-
tion answering (Yih and Ma, 2016)), the triplet
representations are over-simplified for design and

https://github.com/ylongqi/cpk
https://github.com/ylongqi/cpk


creative tasks. These tasks often involve complex
workflows, which require sequential and nested
structures beyond binary relationships between
entities. Our work compensates existing KBC lit-
erature by proposing a new ontology specifically
tailored for CPK. We demonstrate that CPK ex-
traction can benefit from and pose new challenges
to existing approaches.

2.2 Document modeling

Existing work on document modeling has mainly
focused on word-level and document(sentence)-
level predictive tasks, e.g., name entity recogni-
tion, part-or-speech tagging, and semantic pars-
ing (Manning et al., 2014) are used to tag word-
level structures; and document representations (Le
and Mikolov, 2014; Lau and Baldwin, 2016) are
leveraged for sentiment analysis (Maas et al.,
2011), textual similarity comparison (Maas et al.,
2011), question retrieval (Hoogeveen et al., 2015),
and summarization (See et al., 2017). Since many
end applications are built on global contexts, it
is non-trivial to extract documents’ internal struc-
tures using trained predictive models, even with
the attention mechanism (Bahdanau et al., 2014;
See et al., 2017). Prior work on parsing cooking
recipes (Jermsurawong and Habash, 2015; Chen,
2017) produced structured outputs on template
documents, i.e., ingredients are known, and no re-
dundant information is presented. In our work, we
explicitly mine goals and design procedures from
free-text tutorials, which are much more complex
and unstructured. Such an information extrac-
tion poses challenges to existing modeling frame-
works for word or sentence-level tasks and clean
documents. But extracted fine-grained procedures
may benefit traditional document classification,
retrieval and summarization tasks.

2.3 Computational creativity

Recently, the field of computational creativ-
ity (Colton and Wiggins, 2012) has captured
growing attention from academia and industry.
The goal of this field is to create programs that
can master or enhance human-level creativity2.
In the domain of design and arts, researchers
have proposed algorithms that can color grey im-
ages (Zhang et al., 2016), transfer image contex-
tual styles (Li et al., 2017), and synthesis im-
ages (Sangkloy et al., 2017; Ganin et al., 2018).

2https://en.wikipedia.org/wiki/Computational creativity

Command: File >  Open

Usage: open an image

Command: Lasso Tool

Usage: select object area

Command: Image > Adjustments > Hue/Saturation

Usage: adjust object color

Action

Action

Action

Command: File > Save as

Usage: save the image
Action

Workflow

Goal re-color an object in an image

Figure 2: A CPK ontology for the object re-
coloring task. CPK components are colored and
bolded.

In addition, many applications, such as command
search (Adar et al., 2014), command recommenda-
tion (Li et al., 2011), and creative content recom-
mendation (Yang et al., 2017), have been designed
to assist creative professionals to accomplish com-
plex tasks. Moving forward, to truely understand
creativity, it is important to learn fundamental pro-
cedures of design. To that end, our exploration
provides initial resources and insights for scalable
discovery and learning of CPK in the future.

3 Ontology of creative
procedural-knowledge

Each design using software is fundamentally a
process that achieves an artistic objective by com-
pleting a sequence of actions, e.g., to re-color an
object in an image using Photoshop, one needs to
(1) load a target image into the software, (2) se-
lect object area, (3) adjust color, and (4) save the
modified image. All processes that designers de-
veloped for diverse tasks form the CPK. To encode
process-oriented nature, we compose an ontology
of CPK using the workflow representation, which
was adopted to characterize business and scientific
processes (Bergmann and Gil, 2014). In principle,
we represent each design process with two ma-
jor components, a goal and a workflow, and the
workflow ensembles actions (i.e., (command, us-
age) tuples) in a structured manner. A concrete
implementation of the ontology for the object re-
coloring task is shown in Fig. 2. Below are de-
tailed definitions of goal and workflow.

• Goal. The goal defines the objective for a de-
sign process. It typically describes a targeted ar-
tifact or a visual effect. For example, in terms of



digital painting, the goal can be “create charac-
ter concept art”, “paint water, waves and ocean”,
or “turn a pencil sketch into a colorful character
illustration”; and in terms of photo effects, po-
tential goals are “create an architecture sketch
effect”, “add lights to a tree”, or “make some-
one look younger”. In general, goals are not
mutually exclusive, and they more or less relate
to each other, e.g., achieving higher-level goals
may depend on the completion of lower-level
tasks (inclusion), and an abstract goal may cor-
respond to multiple concrete implementations
(hierarchy). In Fig. 2 example, the goal is to
“re-color an object in an image”.

• Workflow. The workflow represents unrolled
and step-by-step actions that need to be per-
formed to accomplish the goal. Each action
specifies a software command to be used and
its usage (i.e., what it is used for). For exam-
ple, the workflow for the task in Fig. 2 contains
four actions (“{}” and “[]” represent an usage
and a command respectively): (1) use [File >
Open] to {open an image}, (2) employ [Lasso
Tool] to {select object area}, (3) {adjust ob-
ject color} through [Image > Adjustments >
Hue/Saturation], and (4) {save the image} using
[File > Save as]. Similar to the goal definition,
workflows also correlate with each other, e.g,
two workflows may share a similar sub-action
sequence. In reality, a comprehensively defined
workflow should be executable given an envi-
ronmental context (i.e., an image).

The canonical knowledge representation makes
it possible to annotate and extract CPK from on-
line design tutorials.

4 Annotating Creative
Procedural-Knowledge

We collect CPK from design tutorials (Fig. 1) that
explicitly or implicitly describe the task that it tries
to accomplish and detailed step-by-step instruc-
tions. To capture a wide range of goals and work-
flows, we consider Adobe Photoshop as the design
software, because of its rich functionality and ac-
tive user community. In this section, we describe
processes of collecting, filtering and annotating tu-
torial webpages. As shown in Fig. 3, the filter-
ing contains two stages, coarse-grained and fine-
grained, that are conducted through Amazon Me-
chanical Turk (AMT) and professional designers

Tutorial 
collection 
(scraping)

Coarse-
grained 
filtering

Fine-grained 
filtering Annotation

Heuristics

Amazon Mechanical Turk (AMT)

Professional Designers (Upwork)

Figure 3: The CPK annotation pipeline. It contains
three steps: scraping, filtering (coarse- and fine-
grained) and annotation.

from Upwork, respectively.

4.1 Tutorial collection
Using Google search engine, we identify 148
valid and unique domains, where each domain
serves more than 10 Photoshop tutorials. We
build a generic web crawler to recursively scrape
all web pages under these domains and only re-
tain pages with the keyword “photoshop”. To
further improve the accuracy of the scraping, for
the 27 largest domains, we build dedicated scrap-
ers tailored for their website structures. Even-
tually, 19.6K web pages are collected. We use
Simhash (Manku et al., 2007) to detect duplicated
documents, which results in 18,100 distinct pages
for further processing.

4.2 Course-grained filtering
The scraped web pages are potentially noisy. For
example, pages may not be Photoshop tutorials.
Also, since we mainly focus on text-based tuto-
rials, web pages that only contain videos are out
of our scope. Because identifying these character-
istics does not require professional design knowl-
edge, we conduct a coarse-grained filtering using
Amazon Mechanical Turk (AMT) platform. For
each web page, two distinct workers are recruited
to use a web application (Fig. 4) to (a) answer the
question “Is the main content of this web page
a single text-based Adobe Photoshop Tutorial?”,
and (b) click on the title of this tutorial (if the
answer is “Yes” to the previous question). The
second task is designed to verify the simple click
made for the first question. Qualified workers
need to satisfy three requirements: (1) “masters”
as determined by AMT platform, (2) have more
than 90% of approval rate, and (3) have completed
more than 100 tasks. The workers are paid for
$10/hour. Finally, 9996 pages receive consistent
ratings from both workers.



Please review the following webpage and answer: Is the main content of this web page 
a single text-based Adobe Photoshop Tutorial?

Yes, it is a single text-based Adobe Photoshop tutorial.

No, it is a single video-only Adobe Photoshop tutorial.

No, it is a catalog of tutorials.

None of the above.

Please click on the title of this tutorial. After the title is selected with the tightest green 

bounding box, click on submit.

(a) Filtering  

(b) Selecting the title 

Figure 4: The web application for coarse-grained
webpage filtering on Amazon Mechanical Turk
(AMT) platform. Each worker is instructed to
complete two tasks: answer a filtering-related
question, and select the title of the tutorial.

4.3 Fine-grained filtering and annotation

Cleaned tutorial pages vary in quality, e.g., some
pages may only contain simple tips, while oth-
ers contain detailed steps for complex tasks. To
achieve quality consistency, we recruit 8 profes-
sional designers from Upwork platform to filter
out low-quality tutorials (those have unclear goals
or use few commands) and annotate high-quality
ones using a web application (Fig. 5). Recruited
designers have 2-10 years of Photoshop experi-
ence and are fluent in English. For each tutorial
page, a designer is assigned to (a) select the text
that describes the title and the goal, (b) use natural
language to summarize the goal (with less than 10
words), and (c) identify actions performed. An-
notations for an action contain the original text,
an used command, and summarization (10 words
maximum) for its usage. These annotations map
unstructured design tutorials into structured CPK
(Section 3).

4.4 Dataset overview

After completing annotations, 819 unique com-
mands and 47,491 actions in 2,022 tutorials are
identified. We show the long-tail distribution of

unigram bigram
Brush Tool New Layer*→Brush Tool
New Layer* Blend Mode†→Opacity†
Blend Mode† Brush Tool→New Layer*

Duplicate Layer‡ Edit>Copy→Edit>Paste
File>Open Brush Tool→Brush Tool

Table 1: Five most frequently annotated unigram
and bigram commands in the dataset (*:Layers, †:
Layer Panel, ‡: Layer)

action density (number of actions per tutorial) in
Fig. 6-(a) — Around 90% of tutorials have less
than 50 actions. In terms of the commands used,
their frequencies are also skewed, as shown in
Fig. 6-(b), (c). The most frequently used tools and
their combinations (Table. 1), such as Brush Tool,
relate to common tasks in digital designs, e.g., ma-
nipulate layers and areas. These demonstrate that
many complex design tasks do not necessarily re-
quire rare tools.

For the goal and usage, the annotations are in
the form of free text. We find that designers tend
to use boilerplate phrases to summarize the goal,
such as “how to”, “learn to”, and “learn how to”.
We remove these phrases using regular expres-
sions since they do not provide content informa-
tion. To visualize the goal summaries, we first de-
rive summary representations using the element-
wise average of GloVe word vectors (Pennington
et al., 2014) (excluding stop words), and then ap-
ply the K-means algorithm to discover underlying
clusters. We set K = 5, and the summaries clos-
est to each cluster center are presented in Table. 2.
The five clusters cover a wide range of design top-
ics, e.g., text effect, photo effect, web design, tex-
tures, and scenes, which demonstrates the diver-
sity of the dataset. In addition, we apply the same
clustering approach to the usage summaries of all
commands. As a result, commands are grouped by
their usage similarities. For example, as shown in
Table. 3, filter- and transform-related commands
are grouped into the cluster 1 and cluster 5, respec-
tively. This demonstrates that CPK reveals seman-
tic relationships between different commands.

5 Extracting creative
procedural-knowledge

The annotated dataset makes it possible to super-
visedly build models to mine and extract CPK. In
this section, we propose a general pipeline that
produces structured knowledge outputs based on



Select action descriptions, identify the command, and summarize its usage

Summarize the goal Select the sentences describing the goal

Select the titleFilter out low-quality tutorials

Is this web page a Photoshop tutorial that 
accomplishes a specific goal using multiple 
commands?

Yes. No.

Use your cursor to select the title of this 
tutorial and then click on submit.

Submit.

This tutorial doesn’t contain a title.

Yes

Use your cursor to select the sentences that 
describe the goal of this tutorial and then click 
on submit.

Submit.

There is no sentence(s) explicitly 
describing the goal of this tutorial.

Summarize the goal using your own language.

Submit.

Summarization (10 words maximum)

Find and enter all the Photoshop commands used in 
this tutorial by the order of usage. After all the 
commands are entered, click on "complete and 
submit" to receive the confirmation code.

Confirm the sentences selection.

(The selected sentences will be displayed here after confirmation)

Describe its usage (10 words maximum)

Submit.

Complete and submit.

*Instructions to enter a command and its usage:
1. Select the sentences that describe the usage of a command 
and then click on "confirm the sentences selection".
2. Search for and choose the command from the list; or select 
"missing command" and manually enter the command name.
3. Describe the command usage using your own language (10 
words maximum).
4. Click on "submit".

1 2

34

5*

Using the cursor to select text.

Figure 5: The web application for professional designers to conduct fine-grained filtering and CPK anno-
tations. Each session consists of five steps: (1) filter out low-quality tutorials, (2) select the title of the
tutorial, (3) select the sentences describing the goal, (4) summarize the goal using less than 10 words,
(5) annotate actions in the order of their usage (continue until all actions are identified). The text can be
directly selected using the cursor.

Cluster 1 Cluster 2 Cluster 3 Cluster 4 Cluster 5

create photo having pretty

good light effects

create dreamy photo

effect using simple tools

and filters

create fun designs

comning text and shapes

create abstract photo

using effects and color

create this trasparent text

effect

create like in my dream

photo effect

create abstract photo

using effects and color

create picture by blending

different images and tools

create a painting from a

photo
create a text effect

create realistic light

around a subject

creating a cool matelic

background using some

filters and effect

create colorful futuristic

looking text effect

create a lomography

photo effect
create a text effect

use fire and blending

modes to create got

theme photos

create a fabric text effect

using layer styles and

texture

creating a landscape

creative image using

structure images

create a-smoke photo

effect
create text effect

create a night scene

image

creating a text effect

using texture and filters

create a modern web

design style

create a colorful photo

manipulation

create a brazil-inspired

text effect in photoshop

Table 2: Five K-means clusters of goal summaries. The K-means algorithm is applied to summary
representations, which are derived by taking the average of GloVe word vectors (Pennington et al., 2014)
excluding stop words (represented with light fonts).



Cluster 1 Cluster 2 Cluster 3 Cluster 4 Cluster 5

Layer>New Adjustment

Layer>Photo Filter
Pen Tool

Layer>New Adjustment

Layer>Color Balance
Layers Panel Edit>Transform>Warp

Filter>Texture>Grain Selection Tool
Layer>New Adjustment

Layer>Selective Color
Eye Icon

Edit>Transform>Forward

Warp

Filter>Distort>Spherize Polygonal Lasso Tool
Image>Adjustments>

Selective Color
Layers>Palette Options Edit>Free Transform

Filter>Texture>Texturizer Move Tool
Image>Adjustments>

Variations

Layer>Layer

Mask>Reveal All

Image>Transform>Free

Transform

Filter>Distort>Ripple
Rectangular Marquee

Tool

Layer>New Adjustment

Layer>Hue/Saturation

Layer>Layer

Mask>Hide All

Edit>Transform>

Perspective

Table 3: Five K-means clusters of commands. The K-means algorithm is applied to commands’ usage
summary representations, which are derived by taking the average of GloVe word vectors (Pennington
et al., 2014) excluding stop words.

Id Sentence Prediction@1 Ground Truth

1
make sure that you have a radial gradient that fades from solid white to

transparent as shown in the image below : on your new layer , create a gradient
and change the blending mode to overlay .

Gradient Tool
Gradient Tool
Blend Mode
New Layer

2 copy ( ctrl + c ) and paste ( ctrl + v ) the selection . Edit>Paste
Edit>Copy
Edit>Paste

3
create another new layer above , use it as clipping mask ( cmd/ctrl + alt + g )

again .
Create Clipping Mask

Create Clipping Mask
New Layer

4 step 2 right click the canvas and choose select inverse to invert the selection . Select>Inverse
Edit>Copy
Edit>Paste

Select>Inverse

(a) True Positive (TP) samples

Id Sentence
1 next you will find a short version of the tutorial but for a more details please watch the video tutorial .

2
we want to sharpen objects in an image without increasing the effect or visibility of those unwanted elements and also in a way that

does not affect the original colors .
3 i hope that you enjoyed this tutorial , and as always i’d love to hear what you think !
4 my recommendation is to work in the early morning hours before the crowds set in .

(b) True Negative (TN) samples (Prediction@1=Ground Truth=“No Action”)

Id Sentence Prediction@1 Ground Truth
1 then create a new shape using round shape tool . Custom Shape Tool Ellipse Tool
2 set it to soft light mode at 16 % opacity . Blend Mode Gradient Map
3 ( i ’ve used # 003200 here . ) Paint Bucket Tool Color Picker

4
then press ctrl+c ( win ) / command+c ( mac ) to copy the image to the clipboard

.
Edit>Copy No Action

5 rename the merged layer to crackedplanet . Rename Layer No Action

(c) False Positive (FP) samples

Id Sentence Ground Truth
1 step 21 : go to the background image layer at the bottom and press ctrl + j . Duplicate Layer
2 painting it just a bit off could make her eyes look unparallel . Clone Stamp Tool

3
draw two lines down from the corner of her eye , and tap it once or twice here and there : brushing the

paint drip : zoomed out , this is what it looks like : time to fix her hair , we’re going to plant a tree on top
of her head , but we need her head to be a little more flat .

Brush Tool

4 adding bottom text step 1 follow the same techniques to add bottom text . Horizontal Type Tool
5 hit command + d to deselect . Gradient Tool
6 once you have opened the actions panel you can begin creating your first lomo leak . Actions Panel

(d) False Negative (FN) samples (Prediction@1=“No Action”)

Table 4: Commands predictions for sample sentences in the testing set. The samples are grouped into
True Positive (TP), True Negative (TN), False Positive (FP), and False Negative (FN). The predictions
are from the fastText model built on the 1,2,3,4-gram features. The Prediction@1 denotes the top label
(either a command or a “No Action”) predicted for each instance.
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Figure 6: Action and command distributions in the
annotated CPK dataset. X-axises are log-scaled
for better visualization.

Webpage Content 
Identification

Action text 
Identification

Command
prediction

Usage
summarization

Goal text 
Identification

Goal
summarization

Figure 7: Proposed CPK extraction pipeline. All
arrows represent data flows. Solid-line arrows ad-
ditionally denote the order for executing modules.
The parallelogram represents the input, Rectangu-
lars represent identification tasks; and Rounded-
rectangulars represent prediction/generation tasks.

unstructured web content (Section 5.1). In addi-
tion, we experiment existing text classification and
summarization algorithms for various components
(Section 5.2). We find and discuss limitations of
existing approaches and challenges of the extrac-
tion task.

5.1 A general extraction pipeline

Inspired by the annotation procedure, we present
an extraction pipeline in Fig. 7. It consists of six
steps: (1) extract main text content from a raw
HTML tutorial webpage; (2) identify a text chunk
that presents the goal of a design task; (3) sum-
marize the goal; (4) identify text segments that de-
scribe actions recursively and orderly; (5) predict
commands used for each action; and (6) summa-
rize the usage of each command. The predictions
and summarizations can leverage the local (identi-
fied text) and global (complete text content) infor-
mation.

5.2 Experimenting existing algorithms

The proposed pipeline decomposes the knowl-
edge extraction task into several sub-tasks, which
can be potentially powered by existing solutions
for text analysis. For example, the command
prediction can be viewed as a multi-label text
classification problem and the usage summariza-
tion can leverage the sequence-to-sequence mod-
els (Sutskever et al., 2014) developed for machine
translation. To explore the extent to which exist-
ing solutions can solve the CPK extraction, we (a)
apply the fastText (Joulin et al., 2017) to iden-
tify action-related text chunks and predict com-
mands, and (b) adapt the neural machine transla-
tion model (Bahdanau et al., 2014) to summarize
commands’ usages. Specifically, we use the boil-
erpipe (Kohlschütter et al., 2010) and the newspa-
per3 packages to extract main content from HTML
pages, and assume the minimum unit for a text
chunk is a sentence. As a result, an action may
span across multiple sentences, and a sentence
may contain multiple actions.

5.2.1 Text chunks identification and
commands prediction

To conduct sentence-level predictions, we use the
NLTK (Bird et al., 2009) to segment clean tuto-
rial text into sentences. In total, 2022 tutorials
are divided into 94,022 segments. For each sen-
tence, a multi-label classifier predicts commands
used or outputs “No Action” indicating that the
sentence does not describe any action. In prac-
tice, the “No Action” is treated as an additional
label, along with all commands that appear more
than 5 times (404 out of 819 satisfy the require-
ment), in the classification. 54% of sentences are
“No Action” labeled. To measure the performance
of fastText, we randomly split sentences into a
training set (62,936 sentences) and a testing set
(31,086 sentences), and experiment N-gram fea-
tures, where N ranges from 1 to 4. The fast-
Text classification performances, in terms of Pre-
cision@1 and Recall@1, are presented in Fig. 8.
Compared to the majority baseline (0.54), fastText
performs significantly better, and the performance
is further improved by adding more N-gram fea-
tures. However, the improvements saturate when
N is larger than 3, and the best performance is still
unsatisfactory.

To more deeply understand the characteristics

3https://github.com/codelucas/newspaper



of the task and its unique challenges, we analyze
errors of the best classifier (built on the 1,2,3,4-
gram features). Specifically, samples of True Pos-
itives (TP), True Negatives (TN), False Positives
(FP), and False Negatives (FN) in the testing set
are shown in Table. 4 (“No Action” is treated
as negative). The TP samples demonstrate that
commands predictions are accurate when they are
explicitly mentioned in the text, e.g., “create a
gradient”(a-1), “paste the selection”(a-2), “use it
as clipping mask” (a-3), and “select inverse to in-
vert the selection” (a-4), etc. Also, according to
TN samples, “No Action” sentences are easy to
classify when the semantics are clearly irrelevant
to tutorial workflows, such as introductory and
conclusive sentences (b-1 and b-3) and side notes
(b-2 and b-4). However, as the sentences become
more complex, the classifier fails under various
scenarios, as discussed below.

• Implicit mention of commands. The command
names may not be explicitly mentioned in the
text. Instead, they may be referred using short-
cuts (d-1 and d-5) or appearances (c-1).

• No direct mention of commands (Latent com-
mands). In many cases, commands are not men-
tioned at all. For example, in c-2, c-3, d-2, and
d-3, text chunks describe the changes to be made
to the canvas; and the usage of a command may
be mentioned out of the given sentence, e.g., d-4
and d-5.

In order to tackle these challenges, we argue
that prediction models need to (1) understand the
global structure of a tutorial; and (2) develop
deeper understandings of the relationships be-
tween commands and their applied consequences.
Among the FP and FN samples, we find some la-
beling errors, such as c-4, c-5, and d-6. These
errors may stem from the label mapping process,
i.e., labels from an action are shared across sen-
tences that the action spans, or are due to the mis-
takes made by annotators. We leave further data
cleaning as future work.

5.2.2 Usage summarization
An usage summarization module takes a raw sen-
tence as the input and generates a command us-
age summary. A natural model that can ac-
complish this task is the sequence-to-sequence
model (Sutskever et al., 2014): a Recurrent Neu-
ral Network (RNN) based encoder “reads” a list of
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Figure 8: Precision and Recall for the command
prediction task evaluated in the testing set. The
performances of four fastText models built on dif-
ferent N-gram features are presented.

dropout
validation testing

0 0.2 0.5 0 0.2 0.5

1-layer 11.73 12.29 13.49 10.33 11.71 12.17

1-layer-att 18.45 19.18 21.53 17.24 17.84 19.70

2-layer 11.37 11.97 13.16 10.03 11.30 12.56

2-layer-att 16.37 16.23 17.18 14.83 15.27 16.85

Table 5: BLEU scores for the usage summarization
task evaluated in the validation and testing sets.
The best performance in either set is bolded. The
naming schema of different algorithms: [num-
ber of layers]-layer-[whether or not the attention
mechanism (Bahdanau et al., 2014) is applied].

raw text tokens and produces a vector representa-
tion. Then a seperate RNN-based decoder takes
the representation as the input and sequentially
generates a list of words as the summary. We ex-
periment the Neural Machine Translation (NMT)
model (Bahdanau et al., 2014), which achieves
competitive translation performance, and a stan-
dard NMT Tensorflow implementation (Luong
et al., 2017) is used. We leverage the Long-Short
Term Memory (LSTM) (Hochreiter and Schmid-
huber, 1997) as the RNN cell and consider three
aspects that vary the design of the NMT model:
(1) with or without the attention mechanism (Bah-
danau et al., 2014), (2) different dropout rates,
and (3) the number of recurrent layers. To eval-
uate summarization performances, sentences that
contain at least one action (43,582 out of 94,022
sentences satisfy the requirement) are randomly
divided into a training set (23,582 sentences), a
validation set (10,000 sentences), and a testing
set (10,000 sentences); and each sentence corre-
sponds to one or more reference summaries. NMT
models are trained on the training set (batch size:
128, iterations: 100,000) using the Adam opti-
mizer (Kingma and Ba, 2014), and the optimal
training iterations are determined by the valida-



tion BLEU scores (Papineni et al., 2002). Finally,
models’ performances are reported using the test-
ing BLEU scores, as shown in Table. 5.

The quantitative results demonstrate that adding
the attention layer and increasing the dropout rate
significantly improve the summarization perfor-
mance, but simply stacking more LSTM layers
does not help. Compared to the machine trans-
lation task where the existing model (Luong et al.,
2017) achieves the BLEU score close to 30, the
best summarization model (BLEU: 21.53) is still
sub-optimal. To better understand errors, simi-
lar to Section 5.2.1, we qualitatively analyze the
outputs of the model layer-1-att-dropout-0.5. In
Table. 6, we present the summaries for sample
sentences in the validation set, along with their
groundtruth references. Our main findings are dis-
cussed as follows.

• Common and preliminary operations are
easy to summarize. These operations include
creating or duplicating layers (6-1, 2), and open-
ing or loading documents (6-3, 4). The model
can easily pick up keywords, such as “create”,
“duplicate”, “layer”, “document” and “file”, and
generate clean summaries accordingly.

• Long text and complex operations pose chal-
lenges to the summarization. The summaries
tend to be incomplete (6-5, 6) or trivial (6-7)
when the input text is long (6-7) or the opera-
tions are complex, e.g., adding diverse effects
and involving multiple (6-7) or long-tail (6-5, 6)
actions.

To handle complex scenarios discussed above,
summarization models need to paraphrase or ac-
curately identify keywords and phrases from long
text descriptions. In addition, similar to com-
mand predictions, understanding diverse effects
that may be described is important for summariz-
ing multiple or uncommon operations.

6 Conclusions and Future work

We formalized and collected annotations for CPK
extractions, which are shown to pose new method-
ological research challenges. As discussed, CPK
has potentials to power intelligent applications for
information retrieval, personalized learning and
autonomous design. Our future work includes fur-
ther cleaning the collected annotations, building
scalable knowledge extractors to populate and en-

rich CPK, and exploring tutorials with other for-
mats, such as videos.
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